aboutsummaryrefslogtreecommitdiffstats
path: root/community/sassc
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-11 03:00:44 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-11 03:01:03 +0000
commitd73ebbab01b1a2afe88f1e4d98215d1080c0d913 (patch)
tree16282fd85b6c8ddab4a79030811bd08dffb0dd61 /community/sassc
parent9e6d3fa0b9dc36c9a4185b99bb4791e0ae98635f (diff)
downloadaports-d73ebbab01b1a2afe88f1e4d98215d1080c0d913.tar.bz2
aports-d73ebbab01b1a2afe88f1e4d98215d1080c0d913.tar.xz
community/sassc: add simple check
Add a simple test as upstream doesn't provide a test suite.
Diffstat (limited to 'community/sassc')
-rw-r--r--community/sassc/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/sassc/APKBUILD b/community/sassc/APKBUILD
index b4b75172d4..df37f1794a 100644
--- a/community/sassc/APKBUILD
+++ b/community/sassc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Thomas Boerger <thomas@webhippie.de>
pkgname=sassc
pkgver=3.4.7
-pkgrel=0
+pkgrel=1
pkgdesc="Libsass command line driver"
url="https://github.com/sass/sassc"
arch="all"
@@ -27,6 +27,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ ./sassc --help > /dev/null
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install