aboutsummaryrefslogtreecommitdiffstats
path: root/community/scapy
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-06-21 01:38:10 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-24 10:43:11 -0300
commit276a870b955cacd7aeb5386b2e4376d625f495d1 (patch)
treefe0fcadaeff98fdf09a46952dca8710ea543ae88 /community/scapy
parentf6ee808741094b25f088c5502a14da11d3a24c02 (diff)
downloadaports-276a870b955cacd7aeb5386b2e4376d625f495d1.tar.bz2
aports-276a870b955cacd7aeb5386b2e4376d625f495d1.tar.xz
community/scapy: rebuild with Python 3
Diffstat (limited to 'community/scapy')
-rw-r--r--community/scapy/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/community/scapy/APKBUILD b/community/scapy/APKBUILD
index a23e98e2d3..10f122ec91 100644
--- a/community/scapy/APKBUILD
+++ b/community/scapy/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=scapy
pkgver=2.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="Powerful interactive packet manipulation"
-url="http://www.secdev.org/projects/scapy/"
+url="https://scapy.net/"
arch="noarch"
license="GPL-3.0-or-later"
-depends="python2"
-makedepends="python2-dev"
+depends="python3"
+makedepends="python3-dev"
install="$pkgname.post-install"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.zip::https://github.com/secdev/$pkgname/archive/v$pkgver.zip"
@@ -17,17 +17,17 @@ builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- python2 setup.py build
+ python3 setup.py build
}
check() {
cd "$builddir"
- python2 setup.py check
+ python3 setup.py check
}
package() {
cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="b7527a955d445c12e7957e8fe060bc0150442ccc75d63cea03c935c135c3f87c853fb4b824f46261e4c6b62a89a116afaf6ee5bdc610b76cbb64a7ba1249affa scapy-2.4.2.zip"