aboutsummaryrefslogtreecommitdiffstats
path: root/community/scapy
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-08-08 06:06:13 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-08-08 06:06:43 +0000
commit83474cb0877c36df70ad43444f46e96c15f9cbe4 (patch)
tree9b00e7922a1c462c6d9096f5b86de234900dc96b /community/scapy
parent543580248f69c9371fb9cd31ed37e68cde0aeced (diff)
downloadaports-83474cb0877c36df70ad43444f46e96c15f9cbe4.tar.bz2
aports-83474cb0877c36df70ad43444f46e96c15f9cbe4.tar.xz
community/scapy: fix license
Diffstat (limited to 'community/scapy')
-rw-r--r--community/scapy/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/community/scapy/APKBUILD b/community/scapy/APKBUILD
index 264feef014..1b356456a5 100644
--- a/community/scapy/APKBUILD
+++ b/community/scapy/APKBUILD
@@ -2,31 +2,27 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=scapy
pkgver=2.4.3
-pkgrel=0
+pkgrel=1
pkgdesc="Powerful interactive packet manipulation"
url="https://scapy.net/"
arch="noarch"
-license="GPL-3.0-or-later"
+license="GPL-2.0"
depends="python3"
makedepends="python3-dev"
install="$pkgname.post-install"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.zip::https://github.com/secdev/$pkgname/archive/v$pkgver.zip"
-
builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 setup.py check
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}