aboutsummaryrefslogtreecommitdiffstats
path: root/community/scrot
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-08 04:46:42 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-09 06:54:48 +0000
commitc566bba0b980990d3a3b8d5b60df477a86384db4 (patch)
tree0aa57dcaa14ca7223c43b7effa866ef0d52c03ab /community/scrot
parent3c79ab6d5643021e0144a3ac7b1f0b9a39e76afa (diff)
downloadaports-c566bba0b980990d3a3b8d5b60df477a86384db4.tar.bz2
aports-c566bba0b980990d3a3b8d5b60df477a86384db4.tar.xz
community/scrot: move from main
- Has no consumers in main and is a desktop application Closes GH-8634
Diffstat (limited to 'community/scrot')
-rw-r--r--community/scrot/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/scrot/APKBUILD b/community/scrot/APKBUILD
new file mode 100644
index 0000000000..9630ba2227
--- /dev/null
+++ b/community/scrot/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=scrot
+pkgver=0.8.18
+pkgrel=0
+pkgdesc="Simple command-line screenshot utility for X"
+url="https://tracker.debian.org/pkg/scrot"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+depends=
+makedepends="giblib-dev imlib2-dev libx11-dev"
+source="http://http.debian.net/debian/pool/main/s/$pkgname/${pkgname}_${pkgver%.*}.orig.tar.gz
+ http://http.debian.net/debian/pool/main/s/$pkgname/${pkgname}_${pkgver%.*}-${pkgver##*.}.debian.tar.xz"
+builddir="$srcdir/$pkgname-${pkgver%.*}"
+
+prepare() {
+ local patch
+ for patch in $(cat "$srcdir"/debian/patches/series); do
+ patch -p1 -d "$builddir" -i "$srcdir/debian/patches/$patch"
+ done
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" docsdir=/usr/share/doc/scrot install
+}
+
+sha512sums="cba8f589e45758ddbfe4e276399a1ecb0dbe29569be5d85d97733e7f64de2911bd2d03e62700ad0c718a1fc886c2e3def9dee1de5cac884f9e65e772cebe838c scrot_0.8.orig.tar.gz
+225a857c2586a0eaaa17e8f3dacdb01c395cefac99be80665c3a26be25b6cc9785a26f16de464829eb26e0e51d7d5420fe7ed79c1bbbd6931043d01a72d9d832 scrot_0.8-18.debian.tar.xz"