aboutsummaryrefslogtreecommitdiffstats
path: root/community/sddm-kcm/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-09 21:48:32 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 15:14:35 -0300
commit6b921d679bf8901d46917f36ca6d670a539e59a9 (patch)
tree729b0bc4a24e239b4ea35298049a377750ae7753 /community/sddm-kcm/APKBUILD
parent0b473fc574aac126de831bc300a305559689778b (diff)
downloadaports-6b921d679bf8901d46917f36ca6d670a539e59a9.tar.bz2
aports-6b921d679bf8901d46917f36ca6d670a539e59a9.tar.xz
community/sddm-kcm: move from testing
Diffstat (limited to 'community/sddm-kcm/APKBUILD')
-rw-r--r--community/sddm-kcm/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/sddm-kcm/APKBUILD b/community/sddm-kcm/APKBUILD
new file mode 100644
index 0000000000..b41a065422
--- /dev/null
+++ b/community/sddm-kcm/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=sddm-kcm
+pkgver=5.16.5
+pkgrel=0
+pkgdesc="Config module for SDDM"
+arch="all !ppc64le !s390x" # Limited by systemsettings -> plasma-workspace -> libksysguard -> qt5-qtwebengine
+url="https://www.kde.org"
+license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-or-later AND GPL-2.0-only"
+depends="sddm systemsettings"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtx11extras-dev qt5-qtdeclarative-dev kcoreaddons-dev ki18n-dev kxmlgui-dev kauth-dev kconfigwidgets-dev kio-dev karchive-dev knewstuff-dev xcb-util-image-dev libxcursor-dev"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="98178c96ccf2405b1811a896053ed1ae371f4e52f0a5c7db6016a506498be1a0eff9c4c6030350aaafe4d9daeacb9386be8bd79f2b80abe1114d098bb6eddbfd sddm-kcm-5.16.5.tar.xz"