aboutsummaryrefslogtreecommitdiffstats
path: root/community/sdl2_ttf
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-26 21:45:24 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-26 23:36:04 -0300
commitef181a8a37992b68a7a9f611ccc4a696e9025885 (patch)
tree53b75037de2e8211b758e198a8b520ffcf8552ce /community/sdl2_ttf
parenta393d67a0e23a82255dd6eb640a81858215a40ff (diff)
downloadaports-ef181a8a37992b68a7a9f611ccc4a696e9025885.tar.bz2
aports-ef181a8a37992b68a7a9f611ccc4a696e9025885.tar.xz
community/sdl2_ttf: move from main
Diffstat (limited to 'community/sdl2_ttf')
-rw-r--r--community/sdl2_ttf/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/sdl2_ttf/APKBUILD b/community/sdl2_ttf/APKBUILD
new file mode 100644
index 0000000000..1f54548270
--- /dev/null
+++ b/community/sdl2_ttf/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: August Klein <amatcoder@gmail.com>
+# Maintainer: August Klein <amatcoder@gmail.com>
+pkgname=sdl2_ttf
+pkgver=2.0.15
+pkgrel=0
+_pkgname=SDL2_ttf
+pkgdesc="A library which allows you to use TrueType fonts in your SDL applications"
+url="http://www.libsdl.org/projects/SDL_ttf/"
+arch="all"
+license="Zlib"
+depends_dev="freetype-dev"
+makedepends="$depends_dev mesa-dev sdl2-dev"
+subpackages="$pkgname-dev"
+options="!check" # no test suite
+source="https://www.libsdl.org/projects/SDL_ttf/release/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="30d685932c3dd6f2c94e2778357a5c502f0421374293d7102a64d92f9c7861229bf36bedf51c1a698b296a58c858ca442d97afb908b7df1592fc8d4f8ae8ddfd SDL2_ttf-2.0.15.tar.gz"