aboutsummaryrefslogtreecommitdiffstats
path: root/community/searx
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-04-19 09:36:20 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-19 09:36:20 +0200
commit98d7a55d513729747b65be2e6e8c197ff79d9290 (patch)
tree5a638b8ebf5d625dab268eede32e3e9135170a4f /community/searx
parent986a2a94405c163191160bde8162440b30fdb587 (diff)
downloadaports-98d7a55d513729747b65be2e6e8c197ff79d9290.tar.bz2
aports-98d7a55d513729747b65be2e6e8c197ff79d9290.tar.xz
community/searx: move from testing
Diffstat (limited to 'community/searx')
-rw-r--r--community/searx/APKBUILD42
-rw-r--r--community/searx/relax-dependencies.patch29
2 files changed, 71 insertions, 0 deletions
diff --git a/community/searx/APKBUILD b/community/searx/APKBUILD
new file mode 100644
index 0000000000..3a8d9dbf88
--- /dev/null
+++ b/community/searx/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=searx
+pkgver=0.16.0
+pkgrel=0
+pkgdesc="Privacy-respecting metasearch engine"
+url="https://asciimoo.github.io/searx/"
+arch="noarch"
+license="AGPL-3.0"
+depends="python3 py3-certifi py3-babel py3-flask py3-flask-babel py3-idna
+ py3-jinja2 py3-lxml py3-pygments py3-openssl py3-dateutil py3-yaml
+ py3-requests"
+makedepends="py3-setuptools"
+options="!check" # many missing deps, e.g. py3-splinter
+source="https://github.com/asciimoo/searx/archive/v$pkgver/searx-$pkgver.tar.gz
+ relax-dependencies.patch"
+
+prepare() {
+ # Searx only searches in $PWD for these by default
+ sed \
+ -e 's|static_path : ""|static_path : "/usr/lib/python3.8/site-packages/searx/static"|' \
+ -e 's|templates_path : ""|templates_path : "/usr/lib/python3.8/site-packages/searx/templates"|' \
+ -i searx/settings.yml
+}
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ # Move the config to /etc
+ mkdir -p "$pkgdir"/etc/searx
+ mv "$pkgdir"/usr/lib/python*/site-packages/searx/settings.yml "$pkgdir"/etc/searx
+}
+
+sha512sums="4ea6d5a3cce8fb2b49d873f1ac16401ae7fb83672e5fe1e1b443b7b8563befeaa61e79e7383b85ff4360cbcf0a4bdf90e16cc7a16394f8b40c364d814404b03b searx-0.16.0.tar.gz
+c536e8ee7b9ca0ae142a51dec209dbd1f8890d16cc966d503448d059eee59acddf448a2899640af109b1531a934e280599af5603deb18b34a9924fd2a57dff6d relax-dependencies.patch"
diff --git a/community/searx/relax-dependencies.patch b/community/searx/relax-dependencies.patch
new file mode 100644
index 0000000000..7ebb59b3d8
--- /dev/null
+++ b/community/searx/relax-dependencies.patch
@@ -0,0 +1,29 @@
+diff --git a/requirements.txt b/requirements.txt
+index 6e4df37..8955910 100644
+--- a/requirements.txt
++++ b/requirements.txt
+@@ -1,12 +1,12 @@
+-certifi==2019.3.9
+-babel==2.7.0
+-flask-babel==0.12.2
+-flask==1.0.2
+-idna==2.8
+-jinja2==2.10.1
+-lxml==4.3.3
+-pygments==2.1.3
+-pyopenssl==19.0.0
+-python-dateutil==2.8.0
+-pyyaml==5.1
+-requests[socks]==2.22.0
++certifi>2019.3.9
++babel>2.7.0<3
++flask-babel>0.12.2<0.13
++flask>1.0.2<2
++idna>2.8<3
++jinja2>2.10.1<3
++lxml>4.3.3<4
++pygments>2.1.3<3
++pyopenssl>19.0.0<20
++python-dateutil>2.8.0<3
++pyyaml>5.1<6
++requests[socks]>2.22.0<3