aboutsummaryrefslogtreecommitdiffstats
path: root/community/shadow
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-06 09:25:58 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-06 09:25:58 +0000
commiteff85e8c6163511b40826467e5d7890ac4e99ff8 (patch)
tree3577707bc932e5cf71c54419bd66b2b2a24dcfb9 /community/shadow
parent87051c8615e9c749e68ddef3d265d42efdaa39d3 (diff)
downloadaports-eff85e8c6163511b40826467e5d7890ac4e99ff8.tar.bz2
aports-eff85e8c6163511b40826467e5d7890ac4e99ff8.tar.xz
community/shadow: add check(), possibly fix ppc64le build
Diffstat (limited to 'community/shadow')
-rw-r--r--community/shadow/APKBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/community/shadow/APKBUILD b/community/shadow/APKBUILD
index 96fb9a1964..453d578d2d 100644
--- a/community/shadow/APKBUILD
+++ b/community/shadow/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=shadow
pkgver=4.2.1
-pkgrel=9
+pkgrel=10
pkgdesc="PAM-using login and passwd utilities (usermod, useradd, ...)"
url="http://pkg-shadow.alioth.debian.org/"
arch="all"
@@ -31,7 +31,11 @@ builddir="$srcdir/shadow-$pkgver"
build() {
cd "$builddir"
- ./configure --prefix=/usr \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --target=$CTARGET \
+ --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
@@ -49,6 +53,11 @@ build() {
make || return 1
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"