aboutsummaryrefslogtreecommitdiffstats
path: root/community/shadow
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-01-28 14:54:33 -0500
committerHenrik Riomar <henrik.riomar@gmail.com>2019-02-01 20:46:03 +0100
commitf22bf6ffef7a8ea2dc9c6ac214af6b4d4e5f67e2 (patch)
treef208e61868756031997c7b7bf5118b7699be4966 /community/shadow
parent1def3a22106ac02cecae3490811435624854a267 (diff)
downloadaports-f22bf6ffef7a8ea2dc9c6ac214af6b4d4e5f67e2.tar.bz2
aports-f22bf6ffef7a8ea2dc9c6ac214af6b4d4e5f67e2.tar.xz
community/shadow: update to 4.6
This also modernizes the APKBUILD and fixes the useradd default shell.
Diffstat (limited to 'community/shadow')
-rw-r--r--community/shadow/APKBUILD29
-rw-r--r--community/shadow/defaults.patch12
-rw-r--r--community/shadow/useradd-usergroups.patch8
3 files changed, 26 insertions, 23 deletions
diff --git a/community/shadow/APKBUILD b/community/shadow/APKBUILD
index 13dc98d7ae..baa8acf139 100644
--- a/community/shadow/APKBUILD
+++ b/community/shadow/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=shadow
-pkgver=4.5
+pkgver=4.6
pkgrel=0
pkgdesc="PAM-using login and passwd utilities (usermod, useradd, ...)"
url="http://pkg-shadow.alioth.debian.org/"
@@ -13,8 +13,8 @@ makedepends="linux-pam-dev"
subpackages="$pkgname-doc $pkgname-dbg $pkgname-uidmap"
source="https://github.com/shadow-maint/shadow/releases/download/$pkgver/shadow-$pkgver.tar.xz
login.pamd
+ defaults.patch
dots-in-usernames.patch
- useradd-usergroups.patch
pam-useradd.patch
"
# secfixes:
@@ -48,9 +48,8 @@ build() {
--without-attr \
--without-tcb \
--without-nscd \
- --without-group-name-max-length \
- || return 1
- make || return 1
+ --without-group-name-max-length
+ make
}
check() {
@@ -61,23 +60,23 @@ check() {
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
# Do not install these pam.d files they are broken and outdated.
- rm "$pkgdir"/etc/pam.d/* || return 1
+ rm "$pkgdir"/etc/pam.d/*
# install some pam.d files based on a patched useradd
for pamf in groupadd groupdel groupmems groupmod \
useradd userdel usermod
do
install -m0644 etc/pam.d/useradd \
- "$pkgdir/etc/pam.d/$pamf" || return 1
+ "$pkgdir/etc/pam.d/$pamf"
done
# nologin is provided by util-linux.
- rm "$pkgdir"/sbin/nologin || return 1
+ rm "$pkgdir"/sbin/nologin
# However, install our own for login.
- cp "$srcdir"/login.pamd "$pkgdir"/etc/pam.d/login || return 1
+ cp "$srcdir"/login.pamd "$pkgdir"/etc/pam.d/login
# /etc/login.defs is not very useful - replace it with an *almost* blank file.
rm "$pkgdir"/etc/login.defs
@@ -85,7 +84,7 @@ package() {
# Avoid conflict with man-pages.
rm "$pkgdir"/usr/share/man/man3/getspnam.3* \
- "$pkgdir"/usr/share/man/man5/passwd.5* || return 1
+ "$pkgdir"/usr/share/man/man5/passwd.5*
}
uidmap() {
@@ -95,16 +94,16 @@ uidmap() {
cd "$subpkgdir"
mkdir -p usr/bin
- mv "$pkgdir"/usr/bin/new*idmap usr/bin/ || return 1
- chmod 4711 usr/bin/new*idmap || return 1
+ mv "$pkgdir"/usr/bin/new*idmap usr/bin/
+ chmod 4711 usr/bin/new*idmap
# Used e.g. for unprivileged LXC containers.
mkdir etc
touch etc/subuid etc/subgid
}
-sha512sums="e57f8db54df23301c229d4be30d4cbb67efa1d1809cffcff79adc480b6019fb2b5fd09e112e82a3f00ad5a6b2994592adac93f70a631cf666b6f4723b61c87b5 shadow-4.5.tar.xz
+sha512sums="e8eee52c649d9973f724bc2d5aeee71fa2e6a2e41ec3487cd6cf6d47af70c32e0cdf304df29b32eae2b6eb6f9066866b5f2c891add0ec87ba583bea3207b3631 shadow-4.6.tar.xz
46a6f83f3698e101b58b8682852da749619412f75dfa85cecad03d0847f6c3dc452d984510db7094220e4570a0565b83b0556e16198ad894a3ec84b3e513d58d login.pamd
+999eb67be2c1d6bcf752ce217ddbed868e4415d3e60676872db1b3da79b1c7d7da6b5d03335297d6358c41e7d21c32ba2df1bd6834ac4ba364b999ed7170f846 defaults.patch
745eea04c054226feba165b635dbb8570b8a04537d41e914400a4c54633c3a9cf350da0aabfec754fb8cf3e58fc1c8cf597b895506312f19469071760c11f31d dots-in-usernames.patch
-49f1d5ded82d2d479805c77d7cc6274c30233596e375b28306b31a33f8fbfc3611dbc77d606081b8300247908c267297dbb6c5d1a30d56095dda53c6a636fb56 useradd-usergroups.patch
0b4587e263cb6be12fa5ae6bc3b3fc4d3696dae355bc67d085dc58c52ff96edb4d163b95db2092b8c2f3310839430cac03c7af356641b42e24ee4aa6410f5cf1 pam-useradd.patch"
diff --git a/community/shadow/defaults.patch b/community/shadow/defaults.patch
new file mode 100644
index 0000000000..5e6a868bb1
--- /dev/null
+++ b/community/shadow/defaults.patch
@@ -0,0 +1,12 @@
+--- shadow-4.6-orig/etc/useradd
++++ shadow-4.6/etc/useradd
+@@ -1,8 +1,7 @@
+ # useradd defaults file
+-GROUP=1000
+ HOME=/home
+ INACTIVE=-1
+ EXPIRE=
+-SHELL=/bin/bash
++SHELL=/bin/ash
+ SKEL=/etc/skel
+ CREATE_MAIL_SPOOL=yes
diff --git a/community/shadow/useradd-usergroups.patch b/community/shadow/useradd-usergroups.patch
deleted file mode 100644
index adf297231a..0000000000
--- a/community/shadow/useradd-usergroups.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- a/etc/useradd
-+++ b/etc/useradd
-@@ -1,5 +1,4 @@
- # useradd defaults file
--GROUP=1000
- HOME=/home
- INACTIVE=-1
- EXPIRE=