aboutsummaryrefslogtreecommitdiffstats
path: root/community/shotwell/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-02-05 08:36:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-02-05 08:38:22 +0000
commitfb3c437b1104778febd1944fe358d225a204c7f8 (patch)
tree43e9ea7ce01b24e21cdcdf9ca669915aca9186ee /community/shotwell/APKBUILD
parent923ac397fdbd6094037dc1ddfac32a4c7706c683 (diff)
downloadaports-fb3c437b1104778febd1944fe358d225a204c7f8.tar.bz2
aports-fb3c437b1104778febd1944fe358d225a204c7f8.tar.xz
community/shotwell: use webkit2gtk
the older webkit is no longer maintained so grab patches from git to use webkit2gtk.
Diffstat (limited to 'community/shotwell/APKBUILD')
-rw-r--r--community/shotwell/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/community/shotwell/APKBUILD b/community/shotwell/APKBUILD
index a0b865fe32..c960b7a884 100644
--- a/community/shotwell/APKBUILD
+++ b/community/shotwell/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shotwell
pkgver=0.22.0
-pkgrel=1
+pkgrel=2
pkgdesc="A digital photo organizer designed for the GNOME desktop environment"
url="http://yorba.org/shotwell/"
arch="all"
@@ -9,12 +9,14 @@ license="LGPL2.1"
install="shotwell.post-upgrade shotwell.post-install shotwell.pre-deinstall"
depends=""
subpackages="$pkgname-lang"
-makedepends="intltool vala libgee-dev libunique3-dev webkitgtk-dev libexif-dev
+makedepends="intltool vala libgee-dev libunique3-dev webkit2gtk-dev libexif-dev
librsvg-dev sqlite-dev eudev-dev dbus-glib-dev libgphoto2-dev
gexiv2-dev libraw-dev librsvg-dev json-glib-dev gnome-doc-utils
m4 gst-plugins-base1-dev bash gtk+3.0-dev rest-dev desktop-file-utils"
install=
-source="https://download.gnome.org/sources/shotwell/${pkgver%.*}/shotwell-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/shotwell/${pkgver%.*}/shotwell-$pkgver.tar.xz
+ git.patch
+ "
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -22,7 +24,7 @@ prepare() {
for i in $source; do
case $i in
*.patch)
- patch -Np0 -i "$srcdir"/$i || return 1
+ patch -p1 -i "$srcdir"/$i || return 1
;;
esac
done
@@ -44,6 +46,9 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="18421a67a1b859caf8542777a42b9ce3 shotwell-0.22.0.tar.xz"
-sha256sums="01b192c5c1c188ecd11bfdb6143d8f177f313c7eab7fe320bd20ac3ca352f831 shotwell-0.22.0.tar.xz"
-sha512sums="486f27a1fa06512a925ecae60504f3cbc487d44834f635efd0897dd20cb304a731c08133ab4b04b32a754235fc8c63dc9b05787b1a0c72a98c89ca91c64f452c shotwell-0.22.0.tar.xz"
+md5sums="18421a67a1b859caf8542777a42b9ce3 shotwell-0.22.0.tar.xz
+37219db8e9f5cdbe8313ded52531228f git.patch"
+sha256sums="01b192c5c1c188ecd11bfdb6143d8f177f313c7eab7fe320bd20ac3ca352f831 shotwell-0.22.0.tar.xz
+7356d294a4befa7e57a4fd5bc6e808343757499abcaf6e29e09b5b2376f027b6 git.patch"
+sha512sums="486f27a1fa06512a925ecae60504f3cbc487d44834f635efd0897dd20cb304a731c08133ab4b04b32a754235fc8c63dc9b05787b1a0c72a98c89ca91c64f452c shotwell-0.22.0.tar.xz
+06b323de90391457c46ac8eb27bc650a67127d27d7b4939a4a422527bb334400bf6b87edc0f713239891977d78cc2909175f6a3fbdf4c12f407c24b10a98ee23 git.patch"