aboutsummaryrefslogtreecommitdiffstats
path: root/community/sigar/APKBUILD
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-05-20 23:17:45 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-06 05:00:22 -0300
commit80d1bbc9cd7bf5ff3f6819465cf25b9a0324babc (patch)
tree5c4681833988c1d4b2ca912a0fbfe8836f6456ad /community/sigar/APKBUILD
parent352362bc23dc02fe57392e63c5940dacf7a44090 (diff)
downloadaports-80d1bbc9cd7bf5ff3f6819465cf25b9a0324babc.tar.bz2
aports-80d1bbc9cd7bf5ff3f6819465cf25b9a0324babc.tar.xz
community/sigar: modernize and enable all arches
Diffstat (limited to 'community/sigar/APKBUILD')
-rw-r--r--community/sigar/APKBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/community/sigar/APKBUILD b/community/sigar/APKBUILD
index 095b01e521..01e1b9ea22 100644
--- a/community/sigar/APKBUILD
+++ b/community/sigar/APKBUILD
@@ -4,21 +4,20 @@ pkgver=1.6.4
pkgrel=1
pkgdesc="System Information Gatherer And Reporter"
url="http://sigar.hyperic.com/"
-arch="x86_64 x86 ppc64le aarch64"
+arch="all"
license="Apache-2.0"
-depends=""
-depends_dev=""
-makedepends="$depends_dev libtirpc-dev perl apache-ant openjdk8"
-install=""
-subpackages=""
+makedepends="libtirpc-dev perl apache-ant openjdk8"
source="https://github.com/hyperic/sigar/archive/sigar-$pkgver.tar.gz
0001-fix-compilation-with-musl-libc.patch
0002-only-enable-the-GNU-libc-strerror_r-on-GNU-libc.patch
0003-build-with-libtirpc-and-gcc5.patch
- fix-aarch64.patch
+ 0004-make-the-package-compile-on-MIPS.patch
+ 0005-no-m64-mips-arm.patch
+ 0006-fix-undefined-symbols.patch
"
builddir="$srcdir"/sigar-sigar-$pkgver
+
build() {
cd "$builddir"/bindings/java
ant
@@ -34,4 +33,6 @@ sha512sums="0515f3501a51357d6ac01dc5e3ecffae10995f347b98c66928adff247b86e52112d2
577f10add8dfe3f1e97375aba06fdecb4ae9d64d75246107cde2183a9efee5eeb8f2c00c072397e2ac4bba2dc49e67c5efef141c609f84a6128d03f3f5187d05 0001-fix-compilation-with-musl-libc.patch
12f68a3c3449b98a45458aa189a633d32ccc9adab83e04e84c8e496c1e0545a58ecc86fdcb68d55b162f5717244f69a48f0a13241b672c909993dc13643c8c64 0002-only-enable-the-GNU-libc-strerror_r-on-GNU-libc.patch
1896f8deb1945dd18283cb391528791b7554b2a4d56c0bc02a58d36a6af2a333782486a508e4d756b558d522d9a759bb3eefe12f0fd1720a9b83426d2b9bf469 0003-build-with-libtirpc-and-gcc5.patch
-e178aa27634fa13784af17fc7af66091b7f1cd51fb54ff2e004755004c7d53e48e08db9982b7c2eec96d0f662bbf32a07346c103f3b31bd5a3e72ef8d8bf44bf fix-aarch64.patch"
+2999ac33ee0346ebb2d390bb4e315e340eb0c5c3e78c078f7687ddfa83b9817d13d46d4e1f7d208c75a49a279d035efb1a50af56c021d068ea313813e013c851 0004-make-the-package-compile-on-MIPS.patch
+c77796ce9d34a42ea8663bf47b119ec1e3b8a4daf938dad7a15a4c11239cd58ee9797725da4c7defa846479db4d8eb190220beafc969c9dac5fa6d5adebf55b6 0005-no-m64-mips-arm.patch
+b85593c1b07c2c7ac3cd66df70e2ab75e615547c14c797c4e6ce0508fc3a02988e5c9055f0dada14bdf0cb060c35129872239f01e9cf0e0481d0038578f93908 0006-fix-undefined-symbols.patch"