aboutsummaryrefslogtreecommitdiffstats
path: root/community/sigar/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-05-03 20:43:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-03 20:43:38 +0000
commit5fe65558eae7567514f51e0f26fb8d675847134d (patch)
treeca6164cc5ba963a77af973c1616c318cd6bc9be6 /community/sigar/APKBUILD
parent5813bbbb225136d5443e8472d1373125b650424d (diff)
downloadaports-5fe65558eae7567514f51e0f26fb8d675847134d.tar.bz2
aports-5fe65558eae7567514f51e0f26fb8d675847134d.tar.xz
community/sigar: move from testing
Diffstat (limited to 'community/sigar/APKBUILD')
-rw-r--r--community/sigar/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/sigar/APKBUILD b/community/sigar/APKBUILD
new file mode 100644
index 0000000000..f920953013
--- /dev/null
+++ b/community/sigar/APKBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=sigar
+pkgver=1.6.4
+pkgrel=0
+pkgdesc="System Information Gatherer And Reporter"
+url="http://sigar.hyperic.com/"
+arch="all"
+license="ASL 2.0"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libtirpc-dev perl apache-ant openjdk8"
+install=""
+subpackages=""
+source="https://github.com/hyperic/sigar/archive/sigar-$pkgver.tar.gz
+ 0001-fix-compilation-with-musl-libc.patch
+ 0002-only-enable-the-GNU-libc-strerror_r-on-GNU-libc.patch
+ 0003-build-with-libtirpc-and-gcc5.patch
+ "
+
+builddir="$srcdir"/sigar-sigar-$pkgver
+build() {
+ cd "$builddir"/bindings/java
+ ant
+}
+
+package() {
+ cd "$builddir"/bindings/java
+ mkdir -p "$pkgdir"/usr/lib
+ install ./sigar-bin/lib/libsigar-*.so "$pkgdir"/usr/lib/
+}
+
+md5sums="b4a5e195755fa084feec3cdadcd964d1 sigar-1.6.4.tar.gz
+6e519321a995126f66995d5d961b5463 0001-fix-compilation-with-musl-libc.patch
+9c739f71c0f9bd0cba16e7d85fc49271 0002-only-enable-the-GNU-libc-strerror_r-on-GNU-libc.patch
+ec4b6b987330d01fdfa94f7f3e62c8f6 0003-build-with-libtirpc-and-gcc5.patch"
+sha256sums="179b04c1eb7e10e50632e1f8c8d25c1bc4d35259f2976bc72686ecfa79a0052e sigar-1.6.4.tar.gz
+be24452bf5960adbe6d7b422ca101d015d52ac0dfabcf0ca973883cab56b6d18 0001-fix-compilation-with-musl-libc.patch
+234551e9b9dd03345bacd589c3b9e66f90d6730db9ddca4d692cf8d779c83009 0002-only-enable-the-GNU-libc-strerror_r-on-GNU-libc.patch
+8d68f10a9a14c54c17276e7d48fb6cf82919ad473f2fdf475cfcab6ca9678a96 0003-build-with-libtirpc-and-gcc5.patch"
+sha512sums="0515f3501a51357d6ac01dc5e3ecffae10995f347b98c66928adff247b86e52112d2bf9cf78b2633941eb9c7fb23f019f4885c41348fe461239e4eebd147253e sigar-1.6.4.tar.gz
+577f10add8dfe3f1e97375aba06fdecb4ae9d64d75246107cde2183a9efee5eeb8f2c00c072397e2ac4bba2dc49e67c5efef141c609f84a6128d03f3f5187d05 0001-fix-compilation-with-musl-libc.patch
+12f68a3c3449b98a45458aa189a633d32ccc9adab83e04e84c8e496c1e0545a58ecc86fdcb68d55b162f5717244f69a48f0a13241b672c909993dc13643c8c64 0002-only-enable-the-GNU-libc-strerror_r-on-GNU-libc.patch
+1896f8deb1945dd18283cb391528791b7554b2a4d56c0bc02a58d36a6af2a333782486a508e4d756b558d522d9a759bb3eefe12f0fd1720a9b83426d2b9bf469 0003-build-with-libtirpc-and-gcc5.patch"