aboutsummaryrefslogtreecommitdiffstats
path: root/community/skopeo
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-29 23:41:40 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-30 00:19:03 -0300
commit93d18f239b06406d46acc2d7b0d9c37d950f8ad4 (patch)
tree5727af9f03adf49409f2ebac80c6bba9533bd648 /community/skopeo
parent1857b211ad2f2a031566b9b54e48d305ed170c06 (diff)
downloadaports-93d18f239b06406d46acc2d7b0d9c37d950f8ad4.tar.bz2
aports-93d18f239b06406d46acc2d7b0d9c37d950f8ad4.tar.xz
community/skopeo: upgrade to 0.1.40
Diffstat (limited to 'community/skopeo')
-rw-r--r--community/skopeo/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/community/skopeo/APKBUILD b/community/skopeo/APKBUILD
index 4b63ea2269..e3ec1f13ab 100644
--- a/community/skopeo/APKBUILD
+++ b/community/skopeo/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=skopeo
-pkgver=0.1.39
-pkgrel=1
+pkgver=0.1.40
+pkgrel=0
pkgdesc="Work with remote images registries - retrieving information, images, signing content"
url="https://github.com/containers/skopeo"
arch="all"
@@ -28,18 +28,15 @@ prepare() {
}
build() {
- cd "$builddir"
export GOPATH="$srcdir"
go build -o bin/$pkgname ./cmd/$pkgname
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
mkdir -p "$pkgdir"/var/lib/atomic/sigstore
install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
install -Dm644 "$builddir"/default-policy.json \
@@ -48,4 +45,9 @@ package() {
"$pkgdir"/etc/containers/registries.d/default.yaml
}
-sha512sums="c4aadc40f9d637c628cd96c204b3e9bc3a928c145521bed2e5046508fc936ff99442dda8b4a4cdd85c4d04e64a9ccee5ea8d563c6ebf4e6020d50d96b921716c skopeo-0.1.39.tar.gz"
+cleanup_srcdir() {
+ go clean -modcache
+ default_cleanup_srcdir
+}
+
+sha512sums="161edb8afa961e48e314cf70a4fcebd971a45a50fc11eab6ec751ba4eb05a8be011d16b83c4ed1fa9d6336846da5f518da006d4476ee4e29a160c629820773d3 skopeo-0.1.40.tar.gz"