aboutsummaryrefslogtreecommitdiffstats
path: root/community/slim/no-slimlock.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-05-24 14:57:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-24 14:57:57 +0000
commit3e027bc404156894ad8388027f6d341db8d80d48 (patch)
treede93f6268371450310390ac7305ec1b3253f9fa7 /community/slim/no-slimlock.patch
parent07fa23375ed9535d64caf5f52bc784b1376e7348 (diff)
downloadaports-3e027bc404156894ad8388027f6d341db8d80d48.tar.bz2
aports-3e027bc404156894ad8388027f6d341db8d80d48.tar.xz
community/slim*: move from main
Diffstat (limited to 'community/slim/no-slimlock.patch')
-rw-r--r--community/slim/no-slimlock.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/community/slim/no-slimlock.patch b/community/slim/no-slimlock.patch
new file mode 100644
index 0000000000..1c728206e4
--- /dev/null
+++ b/community/slim/no-slimlock.patch
@@ -0,0 +1,16 @@
+Fixes building without PAM
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9892c1d..eb1608b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -222,7 +222,9 @@ endif(BUILD_SLIMLOCK)
+ ####### install
+ # slim
+ install(TARGETS slim RUNTIME DESTINATION bin)
+-install(TARGETS slimlock RUNTIME DESTINATION bin)
++if(BUILD_SLIMLOCK)
++ install(TARGETS slimlock RUNTIME DESTINATION bin)
++endif(BUILD_SLIMLOCK)
+
+ if (BUILD_SHARED_LIBS)
+ set_target_properties(libslim PROPERTIES