aboutsummaryrefslogtreecommitdiffstats
path: root/community/slim
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-05-24 14:57:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-24 14:57:57 +0000
commit3e027bc404156894ad8388027f6d341db8d80d48 (patch)
treede93f6268371450310390ac7305ec1b3253f9fa7 /community/slim
parent07fa23375ed9535d64caf5f52bc784b1376e7348 (diff)
downloadaports-3e027bc404156894ad8388027f6d341db8d80d48.tar.bz2
aports-3e027bc404156894ad8388027f6d341db8d80d48.tar.xz
community/slim*: move from main
Diffstat (limited to 'community/slim')
-rw-r--r--community/slim/APKBUILD80
-rw-r--r--community/slim/libslim-underlinking.patch13
-rw-r--r--community/slim/musl-includes.patch10
-rw-r--r--community/slim/no-slimlock.patch16
-rw-r--r--community/slim/slim-freetype-dirs.patch11
-rwxr-xr-xcommunity/slim/slim.initd18
-rw-r--r--community/slim/slim.install7
-rw-r--r--community/slim/slim.logrotate9
-rw-r--r--community/slim/snprintf.patch13
9 files changed, 177 insertions, 0 deletions
diff --git a/community/slim/APKBUILD b/community/slim/APKBUILD
new file mode 100644
index 0000000000..baab693652
--- /dev/null
+++ b/community/slim/APKBUILD
@@ -0,0 +1,80 @@
+# Contributer: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=slim
+pkgver=1.3.6
+pkgrel=9
+pkgdesc="Desktop-independent graphical login manager for X11"
+url="https://sourceforge.net/projects/slim.berlios/files/"
+arch="all"
+license="GPL-2.0"
+options="!check"
+subpackages="$pkgname-doc"
+makedepends="libxmu-dev libpng-dev libjpeg-turbo-dev libxft-dev
+ cmake libxrandr-dev"
+depends="dbus"
+install=
+source="https://downloads.sourceforge.net/project/slim.berlios/${pkgname}-${pkgver}.tar.gz
+ https://dev.alpinelinux.org/~clandmeter/sources/slim-alpinelinux-0.2.0.tar.gz
+ no-slimlock.patch
+ libslim-underlinking.patch
+ slim-freetype-dirs.patch
+ snprintf.patch
+ musl-includes.patch
+ $pkgname.logrotate
+ $pkgname.initd
+ "
+
+prepare() {
+ default_prepare
+ sed -i -e 's|#xserver_arguments.*|xserver_arguments -nolisten tcp vt07|'\
+ -e 's|/var/run/slim.lock|/var/lock/slim.lock|' \
+ -e 's|halt_cmd.*|halt_cmd /sbin/poweroff|'\
+ -e 's|reboot_cmd.*|reboot_cmd /sbin/reboot|'\
+ -e 's|console_cmd.*|console_cmd /usr/bin/terminal|'\
+ -e 's|login_cmd.*|login_cmd exec /bin/sh -l /etc/X11/xinit/xinitrc|' \
+ -e 's|screenshot_cmd.*|screenshot_cmd scrot /slim.png|' \
+ -e 's|imagemagick|scrot|' \
+ -e 's|current_theme.*|current_theme alpinelinux|' \
+ slim.conf
+}
+
+build() {
+ cd "$srcdir/slim-$pkgver"
+ cmake . \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_PAM=no \
+ -DUSE_CONSOLEKIT=no
+
+
+ make CXX="${CXX:-g++}" CC="${CC:-gcc}"
+}
+
+package() {
+ cd "$srcdir/slim-$pkgver"
+ make DESTDIR="$pkgdir" MANDIR=/usr/share/man install
+
+ install -D -m755 ../slim.initd "$pkgdir"/etc/init.d/slim
+ install -D -m644 ../slim.logrotate "$pkgdir"/etc/logrotate.d/slim
+
+ # remove unused systemd service
+ rm -f "$pkgdir"/usr/lib/systemd
+
+ # install our default theme
+ cd "$srcdir"/slim-alpinelinux
+ install -d "$pkgdir"/usr/share/slim/themes/alpinelinux
+ cp background.png panel.png slim.theme \
+ "$pkgdir"/usr/share/slim/themes/alpinelinux/
+ rm -rf "$pkgdir"/usr/share/slim/themes/default
+}
+
+sha512sums="345b1dee5d6f0c3716dfa7c5c16274adbf18586bdaaa6af4f310e24c5a61f79a297ffac921a5ba545523317e9fe120916df226c36b9c9b49c2ac9c1ca21dee0c slim-1.3.6.tar.gz
+3cd3de67e5b1e122da05e02e0e6e8fe2c5a1ae07487e51068aa56ddf05d17854562350ef47c914a2c9fb2534b8f757a326cfed64f4b5ddbbeb18e48af43b46c6 slim-alpinelinux-0.2.0.tar.gz
+3df74cf3c8b2e313b7f394a624c094ec144844003cdd264867a7bd9f46d6a10d9f5e818078340eef76cd52c38bc9ec11989f9dac2f5c693b674c2ec627f447a2 no-slimlock.patch
+c66c3908147ec28b68577958bdd7bd4bc7c42b00fc4a7ce30162202a4d0ae18ef7c0c81ca60c661609e479b370ad30261494fe84bb4ffad48232536aec483729 libslim-underlinking.patch
+1f957eadb586b8f0523a2cf6ea550280a542500de925383a06d658424c524a4ef5b148aa9150a9f045529c896fe69c013417b9883583acc12a7a656b7202eded slim-freetype-dirs.patch
+22fcbdc54b1a5dc0d3501649addb8e290c63ea4a6f9d0bdbdbe9bdea1c9df785f6763f2cee2ff33e6ca2dd49c1c65fd9d036fd9527f298a7ca9e0c5acc48e854 snprintf.patch
+bf1f44814dcf220b91eef8cd766c7eb3b2c2667a211d1206f3e57b88e5e7fbe17ea1e7b3c7c231cb52356b6c7df650af94759b1c154a8dd7d95dc45a9aec0e86 musl-includes.patch
+e5f398ea58adbedea7ae40c7a907d2f926148ee6f3c51fc5761b84d1d119c091fa0cf34f908cd49300fcddea71c5c9b6f2ac21731808ce5d73ea65a65b19a55b slim.logrotate
+042803894dbc34351f2efd436b1e07610f63feb12f31d5d0cc1dc26e758d208790ff79ef678854d3ffd781776bc84033d9b752757944474e721e679d3cbcfbce slim.initd"
diff --git a/community/slim/libslim-underlinking.patch b/community/slim/libslim-underlinking.patch
new file mode 100644
index 0000000000..8db24fe1e4
--- /dev/null
+++ b/community/slim/libslim-underlinking.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index eb1608b..195cefd 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -180,6 +180,8 @@ include_directories(
+ target_link_libraries(libslim
+ ${JPEG_LIBRARIES}
+ ${PNG_LIBRARIES}
++ ${X11_Xft_LIB}
++ ${X11_Xrandr_LIB}
+ )
+
+ #Set up library with all found packages for slim
diff --git a/community/slim/musl-includes.patch b/community/slim/musl-includes.patch
new file mode 100644
index 0000000000..995417eb8e
--- /dev/null
+++ b/community/slim/musl-includes.patch
@@ -0,0 +1,10 @@
+--- slim-1.3.6.orig/panel.cpp
++++ slim-1.3.6/panel.cpp
+@@ -11,6 +11,7 @@
+
+ #include <sstream>
+ #include <poll.h>
++#include <libgen.h>
+ #include <X11/extensions/Xrandr.h>
+ #include "panel.h"
+
diff --git a/community/slim/no-slimlock.patch b/community/slim/no-slimlock.patch
new file mode 100644
index 0000000000..1c728206e4
--- /dev/null
+++ b/community/slim/no-slimlock.patch
@@ -0,0 +1,16 @@
+Fixes building without PAM
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9892c1d..eb1608b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -222,7 +222,9 @@ endif(BUILD_SLIMLOCK)
+ ####### install
+ # slim
+ install(TARGETS slim RUNTIME DESTINATION bin)
+-install(TARGETS slimlock RUNTIME DESTINATION bin)
++if(BUILD_SLIMLOCK)
++ install(TARGETS slimlock RUNTIME DESTINATION bin)
++endif(BUILD_SLIMLOCK)
+
+ if (BUILD_SHARED_LIBS)
+ set_target_properties(libslim PROPERTIES
diff --git a/community/slim/slim-freetype-dirs.patch b/community/slim/slim-freetype-dirs.patch
new file mode 100644
index 0000000000..7379a4cabc
--- /dev/null
+++ b/community/slim/slim-freetype-dirs.patch
@@ -0,0 +1,11 @@
+--- slim-1.3.6.orig/CMakeLists.txt
++++ slim-1.3.6/CMakeLists.txt
+@@ -170,7 +170,7 @@
+ ${X11_Xft_INCLUDE_PATH}
+ ${X11_Xrender_INCLUDE_PATH}
+ ${X11_Xrandr_INCLUDE_PATH}
+- ${FREETYPE_INCLUDE_DIR_freetype2}
++ ${FREETYPE_INCLUDE_DIRS}
+ ${X11_Xmu_INCLUDE_PATH}
+ ${ZLIB_INCLUDE_DIR}
+ ${JPEG_INCLUDE_DIR}
diff --git a/community/slim/slim.initd b/community/slim/slim.initd
new file mode 100755
index 0000000000..fd9a6c426a
--- /dev/null
+++ b/community/slim/slim.initd
@@ -0,0 +1,18 @@
+#!/sbin/openrc-run
+
+depends() {
+ needs localmount dbus
+}
+
+start() {
+ ebegin "Starting slim"
+ start-stop-daemon --start --quiet --exec /usr/bin/slim -- -d
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping slim"
+ start-stop-daemon --stop --quiet --exec /usr/bin/slim
+ eend $?
+}
+
diff --git a/community/slim/slim.install b/community/slim/slim.install
new file mode 100644
index 0000000000..45eb02fa13
--- /dev/null
+++ b/community/slim/slim.install
@@ -0,0 +1,7 @@
+post_install() {
+ cat << _EOF
+
+ Add slim to the DAEMONS array in /etc/rc.conf or update /etc/inittab.
+
+_EOF
+}
diff --git a/community/slim/slim.logrotate b/community/slim/slim.logrotate
new file mode 100644
index 0000000000..26ec3b0f42
--- /dev/null
+++ b/community/slim/slim.logrotate
@@ -0,0 +1,9 @@
+/var/log/slim.log {
+ compress
+ rotate 1
+ size 1024k
+ notifempty
+ missingok
+ copytruncate
+ noolddir
+}
diff --git a/community/slim/snprintf.patch b/community/slim/snprintf.patch
new file mode 100644
index 0000000000..f534ce3fad
--- /dev/null
+++ b/community/slim/snprintf.patch
@@ -0,0 +1,13 @@
+diff --git a/Ck.cpp b/Ck.cpp
+index 3b94426..85cc022 100644
+--- a/Ck.cpp
++++ b/Ck.cpp
+@@ -91,7 +91,7 @@ namespace Ck {
+
+ vt = *((long *)return_value);
+
+- std::snprintf(device, 32, "/dev/tty%ld", vt);
++ snprintf(device, 32, "/dev/tty%ld", vt);
+
+ if(return_value)
+ XFree(return_value);