aboutsummaryrefslogtreecommitdiffstats
path: root/community/sloci-image/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-01-26 16:31:05 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-01-26 16:31:05 +0100
commit35ad6abcf0ba2bf57e58bd06fe7d76f4712087c1 (patch)
tree0da0fc94c00d0c4a100958adbe573c530bb45149 /community/sloci-image/APKBUILD
parent039f225a892fed6678d43a17f093423990753719 (diff)
downloadaports-35ad6abcf0ba2bf57e58bd06fe7d76f4712087c1.tar.bz2
aports-35ad6abcf0ba2bf57e58bd06fe7d76f4712087c1.tar.xz
community/sloci-image: move from testing
Diffstat (limited to 'community/sloci-image/APKBUILD')
-rw-r--r--community/sloci-image/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/sloci-image/APKBUILD b/community/sloci-image/APKBUILD
new file mode 100644
index 0000000000..745b6ba0d0
--- /dev/null
+++ b/community/sloci-image/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=sloci-image
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Simple script for creating single-layer OCI images"
+url="https://github.com/jirutka/sloci-image"
+arch="noarch"
+license="MIT"
+depends="/bin/sh tar"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jirutka/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ ./sloci-image --version
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+sha512sums="ef97a253c8fc8ddf141b5b5985c34fcf890ab881a6c658f7f6200c59ab3a4641e60e0cbe6adc6bafc3cbd348643f5ac7f2308cf650d5468a4e4c998a36597a56 sloci-image-0.1.0.tar.gz"