aboutsummaryrefslogtreecommitdiffstats
path: root/community/slock/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-08-19 13:15:08 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-08-19 13:16:07 +0200
commit31225d654c679aa4dbaa519c3e9ec00b550bd0a5 (patch)
treeb7389e7fa39cd949720f46adfb86839c6237a5af /community/slock/APKBUILD
parent52f074b4090c9559d1b8f2b84da31876cbe821c8 (diff)
downloadaports-31225d654c679aa4dbaa519c3e9ec00b550bd0a5.tar.bz2
aports-31225d654c679aa4dbaa519c3e9ec00b550bd0a5.tar.xz
community/slock: move from testing
Diffstat (limited to 'community/slock/APKBUILD')
-rw-r--r--community/slock/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/slock/APKBUILD b/community/slock/APKBUILD
new file mode 100644
index 0000000000..dcc42b520b
--- /dev/null
+++ b/community/slock/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=slock
+pkgver=1.3
+pkgrel=2
+pkgdesc="A simple screen locker for X"
+url="http://tools.suckless.org/slock/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="libxext-dev libxrandr-dev linux-headers"
+install=""
+options="suid"
+subpackages="$pkgname-doc"
+source="http://dl.suckless.org/tools/$pkgname-$pkgver.tar.gz
+ 0001-clear-passwords-with-explicit_bzero.patch"
+
+builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ default_prepare || return 1
+ sed -i -e '/CFLAGS/{s/-Os//;s/=/+=/}' \
+ -e '/LDFLAGS/{s/-s//;s/=/+=/}' \
+ "$builddir"/config.mk || return 1
+}
+
+build() {
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11 \
+ -C "$builddir" || return 1
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" \
+ -C "$builddir" install || return 1
+}
+
+md5sums="825aaeccba9b3b3c1f3d249d47c1396a slock-1.3.tar.gz
+ca1f6e27e0b86101964c3a0d196d6520 0001-clear-passwords-with-explicit_bzero.patch"
+sha256sums="bab4a3aea4046aa0fd0361c3649b79b90ca531bc5dfae3c4a6c0fe436152bd18 slock-1.3.tar.gz
+4ed77e1955536f4d9cbb104a197a129f1abf0686088cff299ee72537eea56905 0001-clear-passwords-with-explicit_bzero.patch"
+sha512sums="5024588f6d25f9d72a9d2b8ef9d8a2a94e5d5e53f30f4a15df83b693a3706b1ad6550422f36af29f54429a9c516d14a349e46aeb9896c6e32009ff0da5c02a8f slock-1.3.tar.gz
+3b7f03c135694de6aa145587ec272ed21047c2a51e448011cb51ad447a39973a7ec9d760f42aca4dc0d22904b78b2668ffeab4c0a9d24cd6b6af88bb95cdaf38 0001-clear-passwords-with-explicit_bzero.patch"