aboutsummaryrefslogtreecommitdiffstats
path: root/community/smstools/makefile.patch
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2015-11-03 10:00:06 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2015-11-03 10:00:06 +0000
commite341338ef96a84f24f1fe7171235b97a8261e41c (patch)
tree40dae2d492afa5ae888852116ea1af9e0628ccfc /community/smstools/makefile.patch
parentb13fd082726aae6d3a78b356157f72f0be6a48e1 (diff)
downloadaports-e341338ef96a84f24f1fe7171235b97a8261e41c.tar.bz2
aports-e341338ef96a84f24f1fe7171235b97a8261e41c.tar.xz
community/smstools: move from main
Diffstat (limited to 'community/smstools/makefile.patch')
-rw-r--r--community/smstools/makefile.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/smstools/makefile.patch b/community/smstools/makefile.patch
new file mode 100644
index 0000000000..459e5d64a8
--- /dev/null
+++ b/community/smstools/makefile.patch
@@ -0,0 +1,42 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -7,7 +7,7 @@
+ VERSION=$(shell grep package_version src/version.h | cut -f2)
+
+ compile:
+- cd src && $(MAKE) -$(MAKEFLAGS)
++ cd src && $(MAKE)
+
+ install: compile
+ ./install.sh $(BINDIR)
+@@ -16,7 +16,7 @@
+ ./uninstall.sh $(BINDIR)
+
+ clean:
+- cd src && $(MAKE) -$(MAKEFLAGS) clean
++ cd src && $(MAKE) clean
+
+ package: compile clean
+ ./package.sh
+--- ./src/Makefile.orig
++++ ./src/Makefile
+@@ -37,15 +37,15 @@
+ # Use the following only on GNU/Linux and only if you need ps listing like "smsd: MAINPROCESS" and "smsd: GSM1"
+ # CFLAGS += -D USE_LINUX_PS_TRICK
+
+-all: smsd
+-
+-smsd: smsd.c extras.o locking.o cfgfile.o logging.o alarm.o smsd_cfg.o charset.o stats.o blacklist.o whitelist.o modeminit.o pdu.o
+-
+ ifneq (,$(findstring SOLARIS,$(CFLAGS)))
+ ifeq (,$(findstring DISABLE_INET_SOCKET,$(CFLAGS)))
+ override LFLAGS += -lsocket -lnsl
+ endif
+ endif
++
++all: smsd
++
++smsd: smsd.c extras.o locking.o cfgfile.o logging.o alarm.o smsd_cfg.o charset.o stats.o blacklist.o whitelist.o modeminit.o pdu.o
+
+ ifneq (,$(findstring NOSTATS,$(CFLAGS)))
+ $(CC) $(CFLAGS) -o $@ $^ $(LFLAGS)