aboutsummaryrefslogtreecommitdiffstats
path: root/community/spdlog
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-03 04:01:10 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-03 12:13:04 +0100
commitdd502921478ee7eeaeace500929d294a09487a28 (patch)
treeecbd7d0105869ddc2c71b6cfbe84ecdc3ea30e1e /community/spdlog
parentdd8a947d2130b90fc7fb0b2d15cc2153a8393224 (diff)
downloadaports-dd502921478ee7eeaeace500929d294a09487a28.tar.bz2
aports-dd502921478ee7eeaeace500929d294a09487a28.tar.xz
rebuild against libfmt-6.1.0
The soname didn't change but it still broke.
Diffstat (limited to 'community/spdlog')
-rw-r--r--community/spdlog/APKBUILD9
-rw-r--r--community/spdlog/cassert.patch25
2 files changed, 31 insertions, 3 deletions
diff --git a/community/spdlog/APKBUILD b/community/spdlog/APKBUILD
index fe5ecaffc1..9c51439d72 100644
--- a/community/spdlog/APKBUILD
+++ b/community/spdlog/APKBUILD
@@ -2,14 +2,16 @@
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=spdlog
pkgver=1.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="Fast C++ logging library"
url="https://github.com/gabime/spdlog"
arch="all"
license="MIT"
makedepends="cmake fmt-dev"
subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/gabime/spdlog/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gabime/spdlog/archive/v$pkgver.tar.gz
+ cassert.patch
+ "
build() {
mkdir build
@@ -51,4 +53,5 @@ dev() {
rmdir -p "$pkgdir"/usr/lib/spdlog || true
}
-sha512sums="886b489138a1bdf363b5eab65a7d973f570a01c399ff5b910fcfee172ad4ff4d42a45dc2ae24e77b07130df527fb13a86b3e55ac992e72c418aebb232e27eabf spdlog-1.4.2.tar.gz"
+sha512sums="886b489138a1bdf363b5eab65a7d973f570a01c399ff5b910fcfee172ad4ff4d42a45dc2ae24e77b07130df527fb13a86b3e55ac992e72c418aebb232e27eabf spdlog-1.4.2.tar.gz
+f3db0d78bcb6a3e29a061a67cec1583a2f4aee2ecd3309b29315f5c205482dc271eadac49ff186ec36547ab2e7c429b090da73bead82a8bed15b514af53710d8 cassert.patch"
diff --git a/community/spdlog/cassert.patch b/community/spdlog/cassert.patch
new file mode 100644
index 0000000000..18c87b816c
--- /dev/null
+++ b/community/spdlog/cassert.patch
@@ -0,0 +1,25 @@
+diff --git a/include/spdlog/details/pattern_formatter-inl.h b/include/spdlog/details/pattern_formatter-inl.h
+index 1b95eb6..a77a472 100644
+--- a/include/spdlog/details/pattern_formatter-inl.h
++++ b/include/spdlog/details/pattern_formatter-inl.h
+@@ -15,6 +15,7 @@
+
+ #include <array>
+ #include <chrono>
++#include <cassert>
+ #include <ctime>
+ #include <cctype>
+ #include <cstring>
+diff --git a/include/spdlog/details/thread_pool-inl.h b/include/spdlog/details/thread_pool-inl.h
+index 77d0b1f..c773149 100644
+--- a/include/spdlog/details/thread_pool-inl.h
++++ b/include/spdlog/details/thread_pool-inl.h
+@@ -9,6 +9,8 @@
+
+ #include "spdlog/common.h"
+
++#include <cassert>
++
+ namespace spdlog {
+ namespace details {
+