aboutsummaryrefslogtreecommitdiffstats
path: root/community/stow
diff options
context:
space:
mode:
authorStefan Wagner <stw@bit-strickerei.de>2016-08-18 20:01:37 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-18 21:21:06 +0200
commit2f2883cc10692bcb0db5997907b081268fad8d79 (patch)
treed81d38b511465f265bd65324bb46fdfeee4749e6 /community/stow
parentbe6dec1f57e2315d6b3e04d81be7d2220edbdf7f (diff)
downloadaports-2f2883cc10692bcb0db5997907b081268fad8d79.tar.bz2
aports-2f2883cc10692bcb0db5997907b081268fad8d79.tar.xz
testing/[various]: move to community
Diffstat (limited to 'community/stow')
-rw-r--r--community/stow/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/stow/APKBUILD b/community/stow/APKBUILD
new file mode 100644
index 0000000000..64c113a36a
--- /dev/null
+++ b/community/stow/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Stefan Wagner <stw@bit-strickerei.de>
+# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
+pkgname=stow
+pkgver=2.2.2
+pkgrel=0
+pkgdesc="Manage installation of multiple softwares in the same directory tree"
+url="http://www.gnu.org/software/stow/"
+arch="noarch"
+license="GPL2"
+depends="perl"
+makedepends="perl-test-output"
+subpackages="$pkgname-doc"
+source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-pmdir=/usr/lib/perl5/vendor_perl
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ rm "$pkgdir"/usr/share/doc/stow/manual.pdf
+ rm "$pkgdir"/usr/share/doc/stow/version.texi
+}
+
+md5sums="8712d22b7abe26b1bef0e22818981248 stow-2.2.2.tar.gz"
+sha256sums="e2f77649301b215b9adbc2f074523bedebad366812690b9dc94457af5cf273df stow-2.2.2.tar.gz"
+sha512sums="8a3e5da6b5cb4c1ee1b512bae5a9859f83659d5de05f7a9af1dd09df2a32f6b8c6d43b79736db91232c43621d542041d4ef92eb088925796adad0676f200a9b5 stow-2.2.2.tar.gz"