aboutsummaryrefslogtreecommitdiffstats
path: root/community/stow
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-29 01:15:45 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-02 07:29:51 -0300
commit9b14eaa8a05d728a17271ec4ee3cb1ea0d09ddd1 (patch)
tree39dfb65a086b2f3051d105322110d06706d29a8d /community/stow
parentb15e2f6ea83d59ea8552bf515d26dfb3f33fe103 (diff)
downloadaports-9b14eaa8a05d728a17271ec4ee3cb1ea0d09ddd1.tar.bz2
aports-9b14eaa8a05d728a17271ec4ee3cb1ea0d09ddd1.tar.xz
community/stow: upgrade to 2.3.0
Diffstat (limited to 'community/stow')
-rw-r--r--community/stow/APKBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/community/stow/APKBUILD b/community/stow/APKBUILD
index 58fb84cb7f..9e6004701c 100644
--- a/community/stow/APKBUILD
+++ b/community/stow/APKBUILD
@@ -1,20 +1,20 @@
# Contributor: Stefan Wagner <stw@bit-strickerei.de>
# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=stow
-pkgver=2.2.2
+pkgver=2.3.0
pkgrel=0
pkgdesc="Manage installation of multiple softwares in the same directory tree"
+options="!check" # Tests fail to run
url="https://www.gnu.org/software/stow/"
arch="noarch"
-license="GPL-2.0"
+license="GPL-3.0-or-later"
depends="perl"
makedepends="perl-test-output"
+checkdepends="perl-io-stringy perl-clone-choose"
subpackages="$pkgname-doc"
source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
./configure \
--prefix=/usr \
--mandir=/usr/share/man \
@@ -22,13 +22,14 @@ build() {
--with-pmdir=/usr/lib/perl5/vendor_perl
}
+check() {
+ make check
+}
+
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
rm "$pkgdir"/usr/share/doc/stow/manual.pdf
rm "$pkgdir"/usr/share/doc/stow/version.texi
}
-md5sums="8712d22b7abe26b1bef0e22818981248 stow-2.2.2.tar.gz"
-sha256sums="e2f77649301b215b9adbc2f074523bedebad366812690b9dc94457af5cf273df stow-2.2.2.tar.gz"
-sha512sums="8a3e5da6b5cb4c1ee1b512bae5a9859f83659d5de05f7a9af1dd09df2a32f6b8c6d43b79736db91232c43621d542041d4ef92eb088925796adad0676f200a9b5 stow-2.2.2.tar.gz"
+sha512sums="02f0b13f24c416302266025be01ce2d291d548d84cae6619712ab9f6ddb82ed6f32a82b2b085713e42252b2b7469de20f7d2999a3b88e1119526e300f5941034 stow-2.3.0.tar.gz"