aboutsummaryrefslogtreecommitdiffstats
path: root/community/stress-ng/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2019-04-30 17:23:28 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-04-30 17:23:28 +0000
commit8206b9d322ce4b1fe9ec12e6edd831f7dc2ec337 (patch)
treedd2e4f90eab02a7509fbd6987cedf697772e352a /community/stress-ng/APKBUILD
parent9a243b5d1ba5a9fea718b833069b4a0cd93b333b (diff)
downloadaports-8206b9d322ce4b1fe9ec12e6edd831f7dc2ec337.tar.bz2
aports-8206b9d322ce4b1fe9ec12e6edd831f7dc2ec337.tar.xz
community/stress-ng: moved from testing
Diffstat (limited to 'community/stress-ng/APKBUILD')
-rw-r--r--community/stress-ng/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/stress-ng/APKBUILD b/community/stress-ng/APKBUILD
new file mode 100644
index 0000000000..426597192b
--- /dev/null
+++ b/community/stress-ng/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Olliver Schinagl <oliver@schinagl.nl>
+# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
+pkgname=stress-ng
+pkgver=0.09.57
+pkgrel=0
+pkgdesc="stress-ng will stress test a computer system in various selectable ways."
+url="https://kernel.ubuntu.com/~cking/stress-ng/"
+arch="all"
+license="GPL-2.0-or-later"
+options="!check" # tests are not portable
+makedepends="
+ linux-headers
+ libaio-dev
+ libbsd-dev
+ lksctp-tools-dev
+ zlib-dev
+"
+subpackages="$pkgname-doc"
+source="
+ https://kernel.ubuntu.com/~cking/tarballs/stress-ng/stress-ng-$pkgver.tar.xz
+ 0001-Remove-GLOB_ONLYDIR-for-musl.patch
+"
+
+build() {
+ make
+}
+
+package() {
+ make DESTDIR="${pkgdir}" \
+ JOBDIR="/usr/share/doc/${pkgname}/example-jobs/" install
+}
+
+sha512sums="5c3bd06be0f66a6bbb88393b3d22400b5a307e4c45e27d7cb15502370b0873ec11c911aa31fa066400152169ec5bea29c1c0260899dedbc640fbef09ee672cb5 stress-ng-0.09.57.tar.xz
+8b648cdeced325a04c494e84be78182a941ce4c11327c3c0c24bff2caf399ff09a8e88ad19b564f1eb614e9cdc1560377075ec866d90d17a55cb45498b0c3a0d 0001-Remove-GLOB_ONLYDIR-for-musl.patch"