aboutsummaryrefslogtreecommitdiffstats
path: root/community/swayidle
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2019-12-06 23:51:18 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-06 23:56:29 +0100
commitb9e0b88f4e7b9fb1b1bd6be0b29c58906d813bb5 (patch)
treefd805838235353c1d9cd0a27d2797020ac858870 /community/swayidle
parent3a9f5a6ef2ffe876375a38e8acfc2e23fe48a5a6 (diff)
downloadaports-b9e0b88f4e7b9fb1b1bd6be0b29c58906d813bb5.tar.bz2
aports-b9e0b88f4e7b9fb1b1bd6be0b29c58906d813bb5.tar.xz
community/swayidle: add elogind support
build swayidle with elogind support to enable `before-sleep` option
Diffstat (limited to 'community/swayidle')
-rw-r--r--community/swayidle/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/swayidle/APKBUILD b/community/swayidle/APKBUILD
index 2b2acc92a4..4ea427c06b 100644
--- a/community/swayidle/APKBUILD
+++ b/community/swayidle/APKBUILD
@@ -2,13 +2,14 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=swayidle
pkgver=1.5
-pkgrel=0
+pkgrel=1
pkgdesc="Idle management daemon for Wayland"
url="http://swaywm.org"
arch="all"
license="MIT"
options="!check" # no test suite included
makedepends="
+ elogind-dev
meson
ninja
scdoc
@@ -24,7 +25,7 @@ subpackages="
source="$pkgname-$pkgver.tar.gz::https://github.com/swaywm/$pkgname/archive/$pkgver.tar.gz"
build() {
- meson build --prefix /usr
+ meson build -Dlogind=enabled -Dlogind-provider=elogind --prefix /usr
ninja -C build
}