aboutsummaryrefslogtreecommitdiffstats
path: root/community/sword/APKBUILD
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-14 14:04:38 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-09 14:51:11 +0000
commit3eb8c5cc918318648d30499c99e32af58659360e (patch)
treee9e373d66bca24014c009c579bccb406c18858dc /community/sword/APKBUILD
parent32ea9820b49af242f7e508e3c84f813ce035d42c (diff)
downloadaports-3eb8c5cc918318648d30499c99e32af58659360e.tar.bz2
aports-3eb8c5cc918318648d30499c99e32af58659360e.tar.xz
community/sword: modernize abuild
Diffstat (limited to 'community/sword/APKBUILD')
-rw-r--r--community/sword/APKBUILD31
1 files changed, 7 insertions, 24 deletions
diff --git a/community/sword/APKBUILD b/community/sword/APKBUILD
index f7a69007b6..3a3f960cdc 100644
--- a/community/sword/APKBUILD
+++ b/community/sword/APKBUILD
@@ -26,19 +26,9 @@ source="http://www.crosswire.org/ftpmirror/pub/sword/source/v1.7/sword-$pkgver.t
01-osisxhtml-super.patch
"
-_builddir="$srcdir"/sword-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
+builddir="$srcdir"/sword-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
export CXXFLAGS="$CXXFLAGS -std=gnu++98"
./configure \
--build=$CBUILD \
@@ -50,20 +40,19 @@ build() {
--localstatedir=/var \
--with-icu --with-zlib \
--with-curl --with-curl_sftp \
- --with-clucene=/usr \
- || return 1
- make || return 1
+ --with-clucene=/usr
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
mkdir -p -m775 "$pkgdir/var/lib/sword/modules" && \
mv "$pkgdir/usr/share/sword/mods.d" "$pkgdir/var/lib/sword/" && \
chown root:sword "$pkgdir"/var/lib/sword/mod* && \
chmod -R 0775 "$pkgdir/var/lib/sword/mods.d" && \
sed -e 's|\(DataPath=\).*|\1/var/lib/sword/|g' \
- -i "$pkgdir/etc/sword.conf" || return 1
+ -i "$pkgdir/etc/sword.conf"
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
for i in INSTALL README ChangeLog; do
install -Dm644 $i "$pkgdir"/usr/share/doc/sword/$i
@@ -81,12 +70,6 @@ utils() {
mv usr/bin/* "$subpkgdir"/usr/bin
}
-md5sums="1677f02a86cbf07713d4e1d4c39791e6 sword-1.7.4.tar.gz
-cce51448f99b7253a502266e268386b6 00-fflush.patch
-2c69162d27a1cf3e1832c6efc4749b63 01-osisxhtml-super.patch"
-sha256sums="995da8cf5a207c1f09809bf4b9db0bd7d267da5fcdb9d6666c9b313edd9d213d sword-1.7.4.tar.gz
-4c6000d94428cb5150b7debc5a180c17e455ba718b6ef54fa937e9bb4f8c1b80 00-fflush.patch
-02c944ad03636dc8cc716a5aeb5e14ef4f767cc8cbb131dbd2d4e65c31a45071 01-osisxhtml-super.patch"
sha512sums="4c8b183e613367364439cc7a8a842012f75180fccc8eb775b9af2dc4c10f39c152261d35f0aadaaa91a11df36ab1a4057c2edc50ea4b0b3bb0ab0a847ff68f75 sword-1.7.4.tar.gz
6f6c13e7d04458e73d36c114017ad9e76e04c991adb8e457a0b55ce09fcaa95f33b2c26b73c2fd28591f07b69d3d03c1db6d08676001b3a45e0b66b22cb47dc0 00-fflush.patch
98490104a0ef91497a3add3f078158b6fa57c73fc4028f26392716a0efb0957fd029a25239e04a2aa11ebd80583a23a9520a34d18bbf05ff54511d10bdd22bbe 01-osisxhtml-super.patch"