aboutsummaryrefslogtreecommitdiffstats
path: root/community/syndication
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-04-11 11:49:16 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-12 17:37:35 +0000
commit8f7696c13d9e65399b9decf9fa1badc038983a41 (patch)
tree9699aaefb0639f455e9dbd6a11d461ad022ae61f /community/syndication
parentf9801e14dbbc88df60c8a5979d9cdfb124e10801 (diff)
downloadaports-8f7696c13d9e65399b9decf9fa1badc038983a41.tar.bz2
aports-8f7696c13d9e65399b9decf9fa1badc038983a41.tar.xz
community/kde-frameworks: upgrade to 5.69.0
Diffstat (limited to 'community/syndication')
-rw-r--r--community/syndication/APKBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/community/syndication/APKBUILD b/community/syndication/APKBUILD
index 3b172874cc..2170248bfc 100644
--- a/community/syndication/APKBUILD
+++ b/community/syndication/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=syndication
-pkgver=5.68.0
+pkgver=5.69.0
pkgrel=0
pkgdesc="An RSS/Atom parser library"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -12,29 +12,21 @@ makedepends="$depends_dev extra-cmake-modules doxygen graphviz qt5-qttools-dev"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/syndication-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
-prepare() {
- default_prepare
-
- mkdir "$builddir"/build
-}
-
build() {
- cd "$builddir"/build
- cmake "$builddir" \
+ cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
- make
+ make -C build
}
check() {
- cd "$builddir"/build
+ cd build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" make -C build install
}
-sha512sums="ae9e9b22ae4120a452185c613561475e46efc185853d111b298e0372ed0e98dcca524a76acc8a58d1d15c5232c766e096dab21d01dd36135febefdab6f2ac6d0 syndication-5.68.0.tar.xz"
+sha512sums="ad49190674cc65994fb5a0742c2265da28912aafee97fc74e2a6df17add4bae0e3a8ae0a970613e253578af7634df21464f1c9cd8d015551e348c4b1633968b0 syndication-5.69.0.tar.xz"