aboutsummaryrefslogtreecommitdiffstats
path: root/community/sysprof
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:10:42 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:29:46 +0200
commit693c25a6ab8dca449a76e4536580c9d6105bb0fc (patch)
treeeee3fa69cb054b94d1e58caae436acf4449c6bb1 /community/sysprof
parentb182bb26bf4a940494229a1ded55457e22ae5cb1 (diff)
downloadaports-693c25a6ab8dca449a76e4536580c9d6105bb0fc.tar.bz2
aports-693c25a6ab8dca449a76e4536580c9d6105bb0fc.tar.xz
community/sysprof: move from testing
Diffstat (limited to 'community/sysprof')
-rw-r--r--community/sysprof/APKBUILD38
-rw-r--r--community/sysprof/allow-disabling-systemdunitdir.patch32
2 files changed, 70 insertions, 0 deletions
diff --git a/community/sysprof/APKBUILD b/community/sysprof/APKBUILD
new file mode 100644
index 0000000000..3a6586ea56
--- /dev/null
+++ b/community/sysprof/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=sysprof
+pkgver=3.32.0
+pkgrel=0
+pkgdesc="System-wide profiler for Linux"
+url="http://sysprof.com/"
+arch="all !s390x" # tests failing
+license="GPL-2.0-or-later"
+depends_dev="$pkgname=$pkgver-r$pkgrel" # sysprof's lib setup is a bit weird...
+makedepends="meson gtk+3.0-dev itstool glib-dev polkit-dev elogind-dev"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/sysprof/${pkgver%.*}/sysprof-${pkgver}.tar.xz
+ allow-disabling-systemdunitdir.patch"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ -Denable_gtk=true \
+ -Dsystemdunitdir=no \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="7b9d84ac241d376a5e545082b1224e7db96af26ae0ee297d5f0b2d45abc4676e23009dbd560085e5d4879378a8dd79eefb4449df3961fbfd09238bd2056061d0 sysprof-3.32.0.tar.xz
+ea1b850669a2e4750b7ee137cbd341a886744b8d8233633992f0d1eb8bd3efc585b7a4a582cfeb35c3ab5d012d0ed54f6e27f46e17c2f6a4ef6bc121f0a5b723 allow-disabling-systemdunitdir.patch"
diff --git a/community/sysprof/allow-disabling-systemdunitdir.patch b/community/sysprof/allow-disabling-systemdunitdir.patch
new file mode 100644
index 0000000000..4c0329e08c
--- /dev/null
+++ b/community/sysprof/allow-disabling-systemdunitdir.patch
@@ -0,0 +1,32 @@
+diff --git a/data/meson.build b/data/meson.build
+index cc924ae..63dc69b 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -86,16 +86,18 @@ if get_option('with_sysprofd') == 'bundled'
+ )
+
+ systemdunitdir = get_option('systemdunitdir')
+- if systemdunitdir == ''
+- systemdunitdir = dependency('systemd').get_pkgconfig_variable('systemdsystemunitdir')
++ if systemdunitdir != 'no'
++ if systemdunitdir == ''
++ systemdunitdir = dependency('systemd').get_pkgconfig_variable('systemdsystemunitdir')
++ endif
++ configure_file(
++ input: 'sysprof2.service.in',
++ output: 'sysprof2.service',
++ configuration: sysprofdconf,
++ install: true,
++ install_dir: systemdunitdir,
++ )
+ endif
+- configure_file(
+- input: 'sysprof2.service.in',
+- output: 'sysprof2.service',
+- configuration: sysprofdconf,
+- install: true,
+- install_dir: systemdunitdir,
+- )
+
+ i18n.merge_file(
+ input: 'org.gnome.sysprof2.policy.in',