aboutsummaryrefslogtreecommitdiffstats
path: root/community/tcllib
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-04-08 23:33:30 -0400
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-11 19:35:09 +0000
commit307c5c8a2103c8df5728af51929d622f1c22761d (patch)
tree701263561f3a25e34d42f494379453a3367f7215 /community/tcllib
parentfbd3afe301c1d01fb0a02eff8348eaebb8ef5c1c (diff)
downloadaports-307c5c8a2103c8df5728af51929d622f1c22761d.tar.bz2
aports-307c5c8a2103c8df5728af51929d622f1c22761d.tar.xz
community/tcllib: new aport
https://core.tcl.tk/tcllib Tcl Standard Library Closes GH-6255
Diffstat (limited to 'community/tcllib')
-rw-r--r--community/tcllib/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/community/tcllib/APKBUILD b/community/tcllib/APKBUILD
new file mode 100644
index 0000000000..057314acd7
--- /dev/null
+++ b/community/tcllib/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: tcely <tcllib+aports@tcely.33mail.com>
+# Maintainer: tcely <tcllib+aports@tcely.33mail.com>
+pkgname=tcllib
+pkgver=1.19
+pkgrel=0
+pkgdesc="Tcl Standard Library"
+url="https://core.tcl.tk/tcllib"
+arch="noarch"
+license="TCL"
+depends="tcl"
+makedepends="tcl-dev"
+subpackages="$pkgname-doc"
+source="https://core.tcl.tk/$pkgname/uv/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ ./configure \
+ --build="$CBUILD" \
+ --host="$CHOST" \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ sed -i \
+ -e '/UP 1 CALL {::hook::call/s/::hook::call/call/' \
+ modules/hook/hook.test
+ sed -i \
+ -e '/::string::token::shell/s/::string::token::shell/shell/' \
+ modules/string/token_shell.test
+
+ # set user because the tcllib tests use this value
+ USER=${USER:-$(id -un)} make test_batch
+}
+
+# Only SHA256 sums are provided by upstream.
+#sha256sums="4a4f73cc8aca1d6b625717b0ace61205cddaa7768f5f9a0e160dd62abb4177ef tcllib-1.19.tar.xz"
+
+sha512sums="08f549a3513316919c61f015a604aa671a73c0fd59a8a20b916d106e7d7d6f4bd59b485a92307778cfea1b00f78c2972a086b1bf960fe85a26fe273b7ada8d12 tcllib-1.19.tar.xz"