aboutsummaryrefslogtreecommitdiffstats
path: root/community/tcsh/APKBUILD
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-04-29 16:59:47 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-30 06:20:31 +0000
commit165c6945f82ced8716cfb6ef78219582d51d4f42 (patch)
treeff2656517cc4c32055ffdc00dce5de0bf1f504b3 /community/tcsh/APKBUILD
parentb35536c00d1f39c0ac216b82af60a7b363093b47 (diff)
downloadaports-165c6945f82ced8716cfb6ef78219582d51d4f42.tar.bz2
aports-165c6945f82ced8716cfb6ef78219582d51d4f42.tar.xz
community/tcsh: add csh.cshrc and csh.login to /etc
add sysconfdir=/etc option to build() configure set url to current active development on github.com add myself as contributor bump pkgrel
Diffstat (limited to 'community/tcsh/APKBUILD')
-rw-r--r--community/tcsh/APKBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/community/tcsh/APKBUILD b/community/tcsh/APKBUILD
index 2e6e2ebc67..be3c77e225 100644
--- a/community/tcsh/APKBUILD
+++ b/community/tcsh/APKBUILD
@@ -1,10 +1,11 @@
# Contributor: Dan Theisen <djt@hxx.in>
+# Contributor: Milan P. Stanić <mps@arvanta.net>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=tcsh
pkgver=6.20.00
-pkgrel=2
+pkgrel=3
pkgdesc="extended C-shell"
-url="http://www.tcsh.org"
+url="https://github.com/tcsh-org/tcsh"
arch="all"
license="BSD-3-Clause"
depends=""
@@ -15,7 +16,11 @@ subpackages="$pkgname-doc"
options="!checkroot"
source="$pkgname-$pkgver.tar.gz::http://http.debian.net/debian/pool/main/t/tcsh/${pkgname}_${pkgver}.orig.tar.gz
001-sysmalloc.patch
- 002-test_123-posix_fix.patch"
+ 002-test_123-posix_fix.patch
+ csh.login
+ csh.cshrc
+ "
+
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -24,6 +29,7 @@ build() {
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
+ --sysconfdir=/etc \
--bindir=/bin \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
@@ -39,9 +45,15 @@ check() {
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
+ install -Dm0644 "${srcdir}/csh.cshrc" "${pkgdir}/etc/csh.cshrc"
+ install -Dm0644 "${srcdir}/csh.login" "${pkgdir}/etc/csh.login"
+ ln -s tcsh "${pkgdir}/bin/csh"
+ ln -s tcsh.1 "${pkgdir}/usr/share/man/man1/csh.1"
rm -rf "$pkgdir"/usr/share/locale
}
sha512sums="c5635393c22341e62fb9a0b953ddf8871a876ab09deb08c98237f93afa9257b4a3381d1db65eefe769e22ef845db29ab7bc78773f1f609d73c8205689a6683e9 tcsh-6.20.00.tar.gz
40149d8eb2fc0fe5184f3c24c7a1b728e881cc0048ccd37a986c3b2d2094499ec1c37ae2bae4c209fb8a847aa943e83e81f79e3d2f55c59990bc00d9d07f5a94 001-sysmalloc.patch
-b4c1afe04554d117b1402608bcdb243148c0c7b2442bdc10dde3ed6601db5e7c5a2341373f9bdc31fda8860e47a6e152cdcc4e3a8b273742037eebc624df282c 002-test_123-posix_fix.patch"
+b4c1afe04554d117b1402608bcdb243148c0c7b2442bdc10dde3ed6601db5e7c5a2341373f9bdc31fda8860e47a6e152cdcc4e3a8b273742037eebc624df282c 002-test_123-posix_fix.patch
+0800e82a38db731154e8f04e5fad2919bb319fdbc626415f0f95d90b7f802c93071d106cee89f9a7201fb3cb69313b741f5f058aea8f89e86fe69613ca20557d csh.login
+205628d2f0825aab9a1eb3b33b4de2377d010dbb3a098388fb11febda10ca2385ecacaa27c5428dbd7d9d711c913cddca72379c825bfb63385ebc3643253cb37 csh.cshrc"