aboutsummaryrefslogtreecommitdiffstats
path: root/community/telepathy-glib
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-23 13:23:26 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-23 14:25:41 -0300
commit21e2bba8d1b15ecbc1d3fb9973aaf0ddaa428e07 (patch)
tree1a225dddb48d83921d8794ef1248780d6bd6c433 /community/telepathy-glib
parentf1c4d22312525402d0a7aa58ebec37df7181ec35 (diff)
downloadaports-21e2bba8d1b15ecbc1d3fb9973aaf0ddaa428e07.tar.bz2
aports-21e2bba8d1b15ecbc1d3fb9973aaf0ddaa428e07.tar.xz
community/telepathy-glib: use python3 during build
Diffstat (limited to 'community/telepathy-glib')
-rw-r--r--community/telepathy-glib/APKBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/community/telepathy-glib/APKBUILD b/community/telepathy-glib/APKBUILD
index df72d37e13..ea2264cfb2 100644
--- a/community/telepathy-glib/APKBUILD
+++ b/community/telepathy-glib/APKBUILD
@@ -2,18 +2,29 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=telepathy-glib
pkgver=0.24.1
-pkgrel=0
+pkgrel=1
pkgdesc="Library for GLib-based Telepathy components"
url="https://telepathy.freedesktop.org"
arch="all"
license="LGPL-2.1-or-later"
-makedepends="dbus-glib-dev intltool libxslt python glib-dev diffutils vala
- gobject-introspection-dev"
+makedepends="dbus-glib-dev intltool libxslt python3 glib-dev diffutils vala
+ gobject-introspection-dev automake autoconf"
options="!check" # Glib-ERROR duplicate test case path => broken upstream
subpackages="$pkgname-dev $pkgname-doc"
-source="https://telepathy.freedesktop.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"
+source="https://telepathy.freedesktop.org/releases/telepathy-glib/telepathy-glib-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ env LANG=C grep -rl python . | \
+ xargs sed -i \
+ -e 's|/usr/bin/python$|/usr/bin/python3|' \
+ -e 's|/usr/bin/env[ \t]*python$|/usr/bin/python3|'
+
+ autoreconf -fi
+}
build() {
+ export PYTHON=python3
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -22,7 +33,6 @@ build() {
--mandir=/usr/share/man \
--localstatedir=/var \
--enable-vala-bindings
-
make
}