aboutsummaryrefslogtreecommitdiffstats
path: root/community/template-glib
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:10:49 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:29:46 +0200
commit6067c4a25499eb96981b4ac4ca01115dc5cc4a18 (patch)
tree56257628ec9b7383797df1ff36653e99dd8b39a5 /community/template-glib
parent693c25a6ab8dca449a76e4536580c9d6105bb0fc (diff)
downloadaports-6067c4a25499eb96981b4ac4ca01115dc5cc4a18.tar.bz2
aports-6067c4a25499eb96981b4ac4ca01115dc5cc4a18.tar.xz
community/template-glib: move from testing
Diffstat (limited to 'community/template-glib')
-rw-r--r--community/template-glib/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/template-glib/APKBUILD b/community/template-glib/APKBUILD
new file mode 100644
index 0000000000..54384c638e
--- /dev/null
+++ b/community/template-glib/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=template-glib
+pkgver=3.34.0
+pkgrel=0
+pkgdesc="library for template expansion which supports calling into GObject Introspection from templates"
+url="https://gitlab.gnome.org/GNOME/template-glib"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="meson vala gobject-introspection-dev glib-dev flex bison"
+subpackages="$pkgname-dev $pkgname-lang"
+source="https://download.gnome.org/sources/template-glib/${pkgver%.*}/template-glib-$pkgver.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="b89cc9890fd80a6858b34139ce1cd2394a43f598629e59f224f4db798a17457be9a2aa8307828af3591108ed6e9a953936a74df15ed1c8c8af2100306db5a497 template-glib-3.34.0.tar.xz"