aboutsummaryrefslogtreecommitdiffstats
path: root/community/texlive/APKBUILD
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2019-10-02 15:02:59 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-04 18:39:27 +0000
commitd41452edeae70533381fdc7238ae41700be5e669 (patch)
tree58e3a5a1967c09cf871ca485d170785c0e1f63aa /community/texlive/APKBUILD
parentbda9fed96df73fbcb57f586aa89d859541653e43 (diff)
downloadaports-d41452edeae70533381fdc7238ae41700be5e669.tar.bz2
aports-d41452edeae70533381fdc7238ae41700be5e669.tar.xz
community/texlive: Rebuild and fixes
- Added missing xz dependency - Rebuild against new poppler - Fixed warnings in APKBUILD - Dropped support for tlmgr (custom texlive package manager) - tlmgr is no longer needed, as texmf-dist package are now provided by Alpine - it is currently broken anyway - I have no resources to maintain it (but an additional texlive-tlmgr could be easily provided and maintained by someone else) - Using custom package managers in addition to apk requires special care to not break stuff, so not providing it in the default texlive package seems like a good idea
Diffstat (limited to 'community/texlive/APKBUILD')
-rw-r--r--community/texlive/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/community/texlive/APKBUILD b/community/texlive/APKBUILD
index a65dbae039..845bffa17f 100644
--- a/community/texlive/APKBUILD
+++ b/community/texlive/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
pkgname=texlive
pkgver=20190410
-pkgrel=2
+pkgrel=3
pkgdesc="Comprehensive TeX document production system"
url="http://tug.org/texlive/"
arch="all !x86 !ppc64le"
license="GPL"
-depends="perl texmf-dist>=2018.50036"
+depends="perl texmf-dist>=2018.50036 xz"
depends_dev=""
makedepends="freetype-dev libpng-dev poppler-dev icu-dev harfbuzz-dev
cairo-dev pixman-dev zziplib-dev libpaper-dev graphite2-dev
@@ -15,11 +15,12 @@ makedepends="freetype-dev libpng-dev poppler-dev icu-dev harfbuzz-dev
install=""
triggers="$pkgname.trigger=/usr/share/texmf-dist"
subpackages="
+ $pkgname-static
$pkgname-dev
$pkgname-doc
xdvik:xdvi
$pkgname-dvi:dvi
- $pkgname-full:meta
+ $pkgname-full:meta:noarch
$pkgname-xetex:xetex
$pkgname-luatex:lua
"
@@ -28,6 +29,7 @@ source="
poppler-076.patch
"
builddir="$srcdir"/texlive-${pkgver}-source
+options="!check" # No unit tests provided
_luatex="dvilualatex dviluatex lualollipop lualatex"
_pdftex="amstex cslatex csplain eplain etex jadetex latex lollipop mex
@@ -38,9 +40,7 @@ _dvi="afm2tfm bbox dvigif dvipng dvips epsffit extractres includeres ps2eps psbo
# Each poppler version recently broke the API, so special treatment is required
_poppler_ver=0.76.0
-
prepare() {
- cd "$builddir"
default_prepare
local folder="texk/web2c/pdftexdir"
@@ -50,8 +50,6 @@ prepare() {
}
build() {
- cd "$builddir"
-
if [ "$CARCH" = "ppc64le" ] || [ "$CARCH" = "s390x" ] ; then
EXTRA="--disable-luajittex --disable-mfluajit"
fi
@@ -118,7 +116,7 @@ build() {
}
package() {
- cd "$builddir"/build
+ cd build
make DESTDIR="$pkgdir" install
@@ -131,8 +129,11 @@ package() {
ln -s eptex "$pkgdir"/usr/bin/platex
ln -s euptex "$pkgdir"/usr/bin/uplatex
- sed -i -e 's:SELFAUTOPARENT:TEXMFROOT:' \
- "$pkgdir"/usr/share/texmf-dist/scripts/texlive/tlmgr.pl
+ # As Alpine has packaged all TeXlive packages, there is no need for a
+ # separate package manager. apk should be used to get and update texmf-dist
+ rm "$pkgdir"/usr/share/texmf-dist/scripts/texlive/tlmgr.pl
+ rm "$pkgdir"/usr/bin/tlmgr
+
sed -i -e 's:^\(TEXMFROOT *= *\)$SELFAUTOPARENT$:\1/usr/share:g' \
"$pkgdir"/usr/share/texmf-dist/web2c/texmf.cnf
}