aboutsummaryrefslogtreecommitdiffstats
path: root/community/texmf-dist/APKBUILD
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2018-03-06 20:06:48 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-03-06 20:06:48 +0000
commit24b0431754c402817682bc31cf75ea4c170af7c4 (patch)
tree7e73ea23863287704ecffdb58c43f948c401f382 /community/texmf-dist/APKBUILD
parentcf72ff38066b5dea70ebaafd1f794a76d0ee12a7 (diff)
downloadaports-24b0431754c402817682bc31cf75ea4c170af7c4.tar.bz2
aports-24b0431754c402817682bc31cf75ea4c170af7c4.tar.xz
community/texmf-dist: move from testing
Diffstat (limited to 'community/texmf-dist/APKBUILD')
-rw-r--r--community/texmf-dist/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/texmf-dist/APKBUILD b/community/texmf-dist/APKBUILD
new file mode 100644
index 0000000000..593683f409
--- /dev/null
+++ b/community/texmf-dist/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=texmf-dist
+pkgver=2017.44907
+pkgrel=1
+pkgdesc="TeX Live texmf core distribution"
+url="http://tug.org/texlive/"
+arch="noarch"
+license="GPL"
+depends="texlive"
+depends_dev=""
+makedepends="texlive-full xz"
+install=""
+subpackages="${pkgname}-most"
+source="${pkgname}-${pkgver}.tar.xz::https://github.com/maribu/${pkgname}/raw/master/${pkgname}-${pkgver}.tar.xz
+ ${pkgname}-most-${pkgver}.tar.xz::https://github.com/maribu/${pkgname}/raw/master/${pkgname}-most-${pkgver}.tar.xz"
+options="!check"
+triggers="texmf-dist.trigger=/usr/share/texmf-dist"
+unpack() {
+ # Prevent unpacking by overwriting the unpack() function
+ return 0
+}
+
+build(){
+ return 0
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share"
+ cd "${pkgdir}/usr/share"
+ tar xJf "${srcdir}/${pkgname}-${pkgver}.tar.xz"
+}
+
+most() {
+ pkgdesc="TeX Live texmf distribution including most of the TeX Live distribution"
+ depends="${pkgname}"
+ mkdir -p "${subpkgdir}/usr/share"
+ cd "${subpkgdir}/usr/share"
+ tar xJf "${srcdir}/${pkgname}-most-${pkgver}.tar.xz"
+}
+
+sha512sums="9d08aa5850f89bd7a1327a0a2e4aef117ea05cc71d074fc95d3cba4494414426124976703b85c5a2d58b4358d74e9f23bd97b5668c6fa872acf4daf9fb92be27 texmf-dist-2017.44907.tar.xz
+c53926b9a9c1092a35cc1d32593ab46828877ab2faf4f582910a62bda7de6f81d9db61b5c508e768c68a80fa7a0c6470b05f3114a8ff98512fe811198230a8cd texmf-dist-most-2017.44907.tar.xz"