aboutsummaryrefslogtreecommitdiffstats
path: root/community/thttpd/APKBUILD
diff options
context:
space:
mode:
authorRich Felker <dalias@aerifal.cx>2017-11-01 17:51:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-01 18:03:10 +0000
commit0a1fb0d91a5354d312ed66ff48393d405b8f522e (patch)
tree4f190f46099faf427594e79490fdfee3d5b299c7 /community/thttpd/APKBUILD
parentb4e57ea9ba009f96f0c61343ab7166217f0d19ff (diff)
downloadaports-0a1fb0d91a5354d312ed66ff48393d405b8f522e.tar.bz2
aports-0a1fb0d91a5354d312ed66ff48393d405b8f522e.tar.xz
community/thttpd: fix serving of .gz and .Z files
thttpd erroneously treats these files as a compressed transfer encoding rather than as a content type. this causes conforming http clients to strip the compression and save a decompressed version when downloading. since this was historically a common httpd bug, some web browsers work around the problem by detecting the .gz extension and ignoring the server's reported transfer encoding, but others, including wget 1.19.2, save a decompressed file, breaking file integrity checking (based on a hash or signature of the original compressed file) and breaking scripts which pass the -z option to tar when extracting. add a patch which removes thttpd's support for extension-based content transfer encodings, and adds the missing mime types for gzip and compress. the patch has been written to be minimally invasive to the program logic, and thus leaves a for loop that breaks on the first iteration rather than rewriting it.
Diffstat (limited to 'community/thttpd/APKBUILD')
-rw-r--r--community/thttpd/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/community/thttpd/APKBUILD b/community/thttpd/APKBUILD
index fec4ddb691..35db0c9837 100644
--- a/community/thttpd/APKBUILD
+++ b/community/thttpd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=thttpd
pkgver=2.27
-pkgrel=2
+pkgrel=3
pkgdesc="Simple, small, portable, fast, and secure HTTP server"
url="http://www.acme.com/software/thttpd"
arch="all"
@@ -16,6 +16,7 @@ source="http://www.acme.com/software/$pkgname/$pkgname-$pkgver.tar.gz
thttpd.logrotated
thttpd-webgroup.patch
forwarded-for.patch
+ remove_transfer_encoding.patch
thttpd-makeweb-notsuid.patch
"
@@ -77,4 +78,5 @@ f1b86a554177a5f2a343abb4aac6fa9bc06dafd7cabdaf8329e6478bcc296f39a56d839e85ac4bf7
5b2800825583e93cf4be76e71d2840b9894c1779a810d562a0b6145cae0c7504dadfdc1e844f1611a48cca3b4518d41b47e41a68f33043d58ffde85f1e56e3f3 thttpd.logrotated
349721da9e670ca666891f98ca338ae0041c09b353fc42bdd87015803f0b668478be8e48f36d5b56b5e172d3a7b262bf4a71c9619607a068e41c2bc292bde2be thttpd-webgroup.patch
02c079ca104f2358cd20756082657dca96f7a88cbeb611de81504f1581c5e085a7a2765ec55b6e0ae1948803afced85e8a45fc6deb2fef1ec5ba1ba96ce68b4b forwarded-for.patch
+6536ae6c25dbf79aec43e3d0596ad135ab3ab6e7cd3a5e3c895a289114c08c03c20357ffb4542decfc4d508039a5045db71fb36002c8ba94dbd6356cad32bae4 remove_transfer_encoding.patch
1138a827049f73b43ce142c914fad0670bcd4577de16485ade024314c616056ab6789897663d8b6592331354d44065eae7aa712e20f5c930a80513448416fa17 thttpd-makeweb-notsuid.patch"