aboutsummaryrefslogtreecommitdiffstats
path: root/community/thunar-vcs-plugin
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2018-06-24 22:35:57 +0200
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-06 09:15:33 +0000
commit86f7ecbf9fd5aaadeef3076f0e3f0f4e6534258e (patch)
treea43eb66677eda7b2d5ef38485e5a1f6cf7f10df5 /community/thunar-vcs-plugin
parentdeeac93416fa007a1cec2e74ed8ec55b4e0c7e99 (diff)
downloadaports-86f7ecbf9fd5aaadeef3076f0e3f0f4e6534258e.tar.bz2
aports-86f7ecbf9fd5aaadeef3076f0e3f0f4e6534258e.tar.xz
community/thunar-vcs-plugin: upgrade to 0.1.90, modernize
Diffstat (limited to 'community/thunar-vcs-plugin')
-rw-r--r--community/thunar-vcs-plugin/APKBUILD46
1 files changed, 20 insertions, 26 deletions
diff --git a/community/thunar-vcs-plugin/APKBUILD b/community/thunar-vcs-plugin/APKBUILD
index a98afcea8f..d263311bbe 100644
--- a/community/thunar-vcs-plugin/APKBUILD
+++ b/community/thunar-vcs-plugin/APKBUILD
@@ -1,34 +1,29 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=thunar-vcs-plugin
-pkgver=0.1.4
-pkgrel=6
+pkgver=0.1.90
+pkgrel=0
pkgdesc="Version Contol System plugin for the Thunar filemanager"
-url="http://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin"
+url="https://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin"
arch="all"
license="GPL-2.0-or-later"
-depends=
-makedepends="thunar-dev subversion-dev apr-dev util-linux-dev"
-install=""
+options="!check" # no test suite
+depends="thunar"
+makedepends="thunar-dev subversion-dev apr-dev apr-util-dev util-linux-dev"
subpackages="$pkgname-git:_git $pkgname-svn:_svn $pkgname-lang"
-source="http://archive.xfce.org/src/thunar-plugins/thunar-vcs-plugin/0.1/thunar-vcs-plugin-$pkgver.tar.bz2"
+source="https://archive.xfce.org/src/thunar-plugins/thunar-vcs-plugin/0.1/thunar-vcs-plugin-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
-_builddir="$srcdir"/thunar-vcs-plugin-$pkgver
prepare() {
- local i
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ cd "$builddir"
+ default_prepare
+
# quick and dirty fix for apr linking
sed -i -e 's/APR_LDFLAGS/APR_LIBS/' thunar-vcs-plugin/Makefile.in
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -36,27 +31,26 @@ build() {
--libexecdir=/usr/lib/xfce4 \
--disable-static \
--enable-subversion \
- --enable-git \
- || return 1
- make || return 1
+ --enable-git
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
_mv_files() {
local i
for i in "$@"; do
mkdir -p "$subpkgdir"/${i%/*}
- mv "$pkgdir"/$i "$subpkgdir"/$i || return 1
+ mv "$pkgdir"/$i "$subpkgdir"/$i
done
}
_git() {
pkgdesc="Git support for thunar-vcs-plugin"
- depends=
+ depends=""
install_if="$pkgname=$pkgver-r$pkgrel git"
cd "$pkgdir"
_mv_files usr/lib/xfce4/tvp-git-helper \
@@ -65,11 +59,11 @@ _git() {
_svn() {
pkgdesc="Subversion support for thunar-vcs-plugin"
- depends=
+ depends=""
install_if="$pkgname=$pkgver-r$pkgrel subversion"
cd "$pkgdir"
_mv_files usr/lib/xfce4/tvp-svn-helper \
usr/share/icons/hicolor/*/apps/subversion.png
}
-sha512sums="037ca986ab9030146fc409d78d235a157b956b202449ef8e68de77dfce29ba2dd9a2dabc793215dd9ce455f97d8c5400ba51c8254b3c07b3e0d87572df672151 thunar-vcs-plugin-0.1.4.tar.bz2"
+sha512sums="6231bb863d9b884cd27f26e6cabbc3f8d3b39dc162f867932923408636bb96621bb60aa1bfa9b4637f5eed694e623cd911e855dde00d382b2a1bf36bb6b44e63 thunar-vcs-plugin-0.1.90.tar.bz2"