aboutsummaryrefslogtreecommitdiffstats
path: root/community/thunar
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
commit27d1e194717b1696b3169ad43df027876247b91a (patch)
tree8416dc507bc2aed5f47588d345abe1ef22a6c60f /community/thunar
parent0090cfe5db52bd764631d9b1d55e6e74c7cf2ae8 (diff)
downloadaports-27d1e194717b1696b3169ad43df027876247b91a.tar.bz2
aports-27d1e194717b1696b3169ad43df027876247b91a.tar.xz
main/{xfce*} => community/
Move everything xfce to community
Diffstat (limited to 'community/thunar')
-rw-r--r--community/thunar/APKBUILD73
-rw-r--r--community/thunar/thunar-sendto-audacious-playlist.desktop14
-rw-r--r--community/thunar/thunar-sendto-bluetooth.desktop13
l---------community/thunar/thunar.post-deinstall1
-rw-r--r--community/thunar/thunar.post-install5
l---------community/thunar/thunar.post-upgrade1
6 files changed, 107 insertions, 0 deletions
diff --git a/community/thunar/APKBUILD b/community/thunar/APKBUILD
new file mode 100644
index 0000000000..bc8fe6d68b
--- /dev/null
+++ b/community/thunar/APKBUILD
@@ -0,0 +1,73 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=thunar
+pkgver=1.6.12
+pkgrel=1
+pkgdesc="File manager for Xfce"
+url="http://thunar.xfce.org"
+arch="all"
+license="GPL-2.0 LGPL-2.0"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+depends="desktop-file-utils hicolor-icon-theme shared-mime-info"
+depends_dev="exo-dev"
+makedepends="$depends_dev libexif-dev xfce4-panel-dev pcre-dev libgudev-dev
+ libnotify-dev startup-notification-dev libxfce4ui-dev dbus-glib-dev
+ gtk-doc gtk+2.0-dev glib-dev"
+install=
+source="http://archive.xfce.org/src/xfce/thunar/${pkgver%.*}/Thunar-$pkgver.tar.bz2
+ thunar-sendto-audacious-playlist.desktop
+ thunar-sendto-bluetooth.desktop
+ "
+
+builddir="$srcdir"/Thunar-$pkgver
+
+prepare() {
+ cd "$builddir"
+ # fix icon in thunar-sendto-email.desktop
+ sed -i 's!internet-mail!mail-message-new!' \
+ plugins/thunar-sendto-email/thunar-sendto-email.desktop.in.in
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-exif \
+ --enable-pcre \
+ --enable-dbus \
+ --enable-gio-unix \
+ --enable-gudev \
+ --enable-gtk-doc
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ local f
+ make DESTDIR="$pkgdir" install
+ sed -i -e 's:x-directory/gnome-default-handler;::' \
+ "$pkgdir"/usr/share/applications/Thunar-folder-handler.desktop
+ for f in $source; do
+ case $f in
+ thunar-sendto*.desktop)
+ install -m644 "$srcdir"/$f \
+ "$pkgdir"/usr/share/Thunar/sendto/
+ ;;
+ esac
+ done
+}
+
+sha512sums="d18e0fb6b58a65889dc47852a4c513acb7ff9a99fd70d34cbc6b2806d7818893b3c999c0a63f1b7af599d3ff4336b9637944989b97e5cc7431761ce493d2259d Thunar-1.6.12.tar.bz2
+dce525f22abf8e723111673b8fdad48079d5379cef49cc013383bb0944274cdd0de1dda6e8894dd8c9efb54cc9eea2baf8f4c76265665b84f3f58aeb01c72390 thunar-sendto-audacious-playlist.desktop
+b4e8024e093b8e3f9bf5d460335fd9d19c1e394383bd58a7ac05c720103612dea9dde8a02f090f0af09d89e6644b292236ef257dd1790eccd627efce0577828e thunar-sendto-bluetooth.desktop"
diff --git a/community/thunar/thunar-sendto-audacious-playlist.desktop b/community/thunar/thunar-sendto-audacious-playlist.desktop
new file mode 100644
index 0000000000..97f9853180
--- /dev/null
+++ b/community/thunar/thunar-sendto-audacious-playlist.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Version=1.0
+Name=Audacious Playlist
+Name[de]=Audacious Wiedergabeliste
+GenericName=Audio Playlist
+GenericName[de]= Wiedergabeliste
+Comment=Enque files to playlist
+Comment[de]=Dateien zur Wiedergabeliste hinzufügen
+Exec=audacious -e %F
+TryExec=audacious
+Icon=audacious
+MimeType=audio/prs.sid;audio/x-flac;audio/x-it;audio/x-mod;audio/x-ms-wma;audio/x-musepack;audio/x-s3m;audio/x-stm;audio/x-xm;application/ogg;audio/x-vorbis+ogg;inode/directory;
+Terminal=false
+Type=Application
diff --git a/community/thunar/thunar-sendto-bluetooth.desktop b/community/thunar/thunar-sendto-bluetooth.desktop
new file mode 100644
index 0000000000..98899f69ab
--- /dev/null
+++ b/community/thunar/thunar-sendto-bluetooth.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Version=1.0
+Name=Bluetooth OBEX Recipient
+Name[de]=Bluetooth OBEX Empfänger
+GenericName=Bluetooth Recipient
+GenericName[de]=Bluetooth Empfänger
+Comment=Send selected files via Bluetooth
+Comment[de]=Ausgewählte Dateien per Bluetooth senden
+Exec=bluetooth-sendto %F
+TryExec=bluetooth-sendto
+Icon=bluetooth
+Terminal=false
+Type=Application
diff --git a/community/thunar/thunar.post-deinstall b/community/thunar/thunar.post-deinstall
new file mode 120000
index 0000000000..b2d507f24a
--- /dev/null
+++ b/community/thunar/thunar.post-deinstall
@@ -0,0 +1 @@
+thunar.post-install \ No newline at end of file
diff --git a/community/thunar/thunar.post-install b/community/thunar/thunar.post-install
new file mode 100644
index 0000000000..591dfaf728
--- /dev/null
+++ b/community/thunar/thunar.post-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+update-desktop-database -q
+gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
diff --git a/community/thunar/thunar.post-upgrade b/community/thunar/thunar.post-upgrade
new file mode 120000
index 0000000000..b2d507f24a
--- /dev/null
+++ b/community/thunar/thunar.post-upgrade
@@ -0,0 +1 @@
+thunar.post-install \ No newline at end of file