aboutsummaryrefslogtreecommitdiffstats
path: root/community/totem
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:27:50 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:29:48 +0200
commit5b74348a7f26d6b31a7f190991a3384a19665b22 (patch)
tree08b7144dd7e12058b8eabc5e66121c2c29b2eeb9 /community/totem
parentf9bf17283eb22aa286ee10bb965e1a8b0b2ad9d5 (diff)
downloadaports-5b74348a7f26d6b31a7f190991a3384a19665b22.tar.bz2
aports-5b74348a7f26d6b31a7f190991a3384a19665b22.tar.xz
community/totem: move from testing
Diffstat (limited to 'community/totem')
-rw-r--r--community/totem/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/totem/APKBUILD b/community/totem/APKBUILD
new file mode 100644
index 0000000000..f3d147abc3
--- /dev/null
+++ b/community/totem/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=totem
+pkgver=3.34.0
+pkgrel=1
+pkgdesc="Movie player for the GNOME desktop"
+url="https://wiki.gnome.org/Apps/Videos"
+arch="all"
+license="GPL-2.0-or-later"
+depends="gsettings-desktop-schemas gst-plugins-good grilo-plugins"
+makedepends="meson glib-dev gtk+3.0-dev gstreamer-dev libpeas-dev totem-pl-parser-dev
+ gobject-introspection-dev clutter-gtk-dev py-gobject3-dev grilo-dev
+ gnome-desktop-dev vala gsettings-desktop-schemas-dev gst-plugins-base-dev
+ libxml2-dev gstreamer-tools clutter-gst-dev itstool"
+checkdepends="xvfb-run"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/totem/${pkgver%.*}/totem-$pkgver.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+check() {
+ xvfb-run ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="364a1446ab1d7de745cd4783ad14eade7cf6f5eb06bfb0289f17fb154918640478fdbd075c3833ac1c0e5e57a63b5d7225e81d764eb78a89068da697a1c4e511 totem-3.34.0.tar.xz"