aboutsummaryrefslogtreecommitdiffstats
path: root/community/ttf-opensans
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-09-15 12:43:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-15 13:37:11 +0000
commit0d4667363c89e53a83538d90acdc612739d061db (patch)
tree2acca48832bb94561874f4bb8ac971e535badeb8 /community/ttf-opensans
parentc9b19d2f9f7e08b30f5352ed38ef2ca99ad1f373 (diff)
downloadaports-0d4667363c89e53a83538d90acdc612739d061db.tar.bz2
aports-0d4667363c89e53a83538d90acdc612739d061db.tar.xz
community/ttf-opensans: move from testing
needed by chromium for headless
Diffstat (limited to 'community/ttf-opensans')
-rw-r--r--community/ttf-opensans/APKBUILD28
-rw-r--r--community/ttf-opensans/ttf-opensans.post-install4
2 files changed, 32 insertions, 0 deletions
diff --git a/community/ttf-opensans/APKBUILD b/community/ttf-opensans/APKBUILD
new file mode 100644
index 0000000000..d2adf0781d
--- /dev/null
+++ b/community/ttf-opensans/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ttf-opensans
+pkgver=1.10
+pkgrel=0
+pkgdesc="Open Sans is a humanist sans serif typeface designed by Steve Matteson"
+url="http://opensans.com/"
+arch="noarch"
+license="Apache"
+depends="fontconfig mkfontdir mkfontscale"
+makedepends="font-util-dev"
+install="$pkgname.post-install"
+source="http://ie.archive.ubuntu.com/ftp.frugalware.org/pub/frugalware/frugalware-current/source/xlib-extra/open-sans/$pkgname-$pkgver.zip"
+builddir="$srcdir"
+
+build() {
+ cd "$builddir"
+ return 0
+}
+
+package() {
+ cd "$builddir"
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -m644 *.ttf "$pkgdir/usr/share/fonts/TTF/"
+}
+md5sums="bfe34b6473988efb5de7cf226975249f ttf-opensans-1.10.zip"
+sha256sums="f14979b4a358311e51da601a2debb7f21a639912fa06d88825056c41d792871e ttf-opensans-1.10.zip"
+sha512sums="6e14d6bc8ed225d04016c237a43909032aae434111bd21b9e4a0889fa84b1dc6d4487d8c465f53308523ee93e7f45cf1f2e78a0db6c64b9a5d7f13a6b2579688 ttf-opensans-1.10.zip"
diff --git a/community/ttf-opensans/ttf-opensans.post-install b/community/ttf-opensans/ttf-opensans.post-install
new file mode 100644
index 0000000000..984457d3e1
--- /dev/null
+++ b/community/ttf-opensans/ttf-opensans.post-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+fc-cache -f > /dev/null
+mkfontscale /usr/share/fonts/TTF
+mkfontdir /usr/share/fonts/TTF