aboutsummaryrefslogtreecommitdiffstats
path: root/community/ttyd/fix-cmake.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-23 21:57:56 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-23 21:58:54 +0100
commit0adb5cd4c407e2984018e98010b5ec4e9c908ec5 (patch)
treee6b863ba93d81bb42cc4adcb1998c3667bd6ef53 /community/ttyd/fix-cmake.patch
parentd75c4d16ff00f0cfba4d2cf49da91c8b73402219 (diff)
downloadaports-0adb5cd4c407e2984018e98010b5ec4e9c908ec5.tar.bz2
aports-0adb5cd4c407e2984018e98010b5ec4e9c908ec5.tar.xz
community/ttyd: move from testing
Diffstat (limited to 'community/ttyd/fix-cmake.patch')
-rw-r--r--community/ttyd/fix-cmake.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/community/ttyd/fix-cmake.patch b/community/ttyd/fix-cmake.patch
new file mode 100644
index 0000000000..274bfcb7ef
--- /dev/null
+++ b/community/ttyd/fix-cmake.patch
@@ -0,0 +1,20 @@
+find_package doesn't find Libwebsockets (with capital "L"). Eventually it finds
+libwebsockets with pkg-config, but includes libwebsockets.a on the path first,
+so the resulting library links libwebsockets statically.
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -13,11 +13,11 @@
+ set(SOURCE_FILES src/server.c src/http.c src/protocol.c src/utils.c)
+
+ find_package(OpenSSL REQUIRED)
+-find_package(Libwebsockets ${LIBWEBSOCKETS_MIN_VERSION} QUIET)
++find_package(libwebsockets ${LIBWEBSOCKETS_MIN_VERSION} QUIET)
+
+ find_package(PkgConfig)
+
+-if(Libwebsockets_FOUND)
++if(libwebsockets_FOUND)
+ set(LIBWEBSOCKETS_INCLUDE_DIR ${LIBWEBSOCKETS_INCLUDE_DIR} ${LIBWEBSOCKETS_INCLUDE_DIRS})
+ else() # try to find libwebsockets with pkg-config
+ pkg_check_modules(Libwebsockets REQUIRED libwebsockets>=${LIBWEBSOCKETS_MIN_VERSION})