aboutsummaryrefslogtreecommitdiffstats
path: root/community/udisks
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2019-09-16 14:56:12 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-09-17 11:25:06 -0300
commit171e679e801abe620b51310b66375a2517592fe6 (patch)
tree4ccbc976f5515b5454cf314c2a634c8eb0ed2216 /community/udisks
parent97f135ca973bff59fde9c4a5cbf2fc34ab034ac3 (diff)
downloadaports-171e679e801abe620b51310b66375a2517592fe6.tar.bz2
aports-171e679e801abe620b51310b66375a2517592fe6.tar.xz
community/udisks: add required sysmacros.h
Diffstat (limited to 'community/udisks')
-rw-r--r--community/udisks/APKBUILD6
-rw-r--r--community/udisks/udisks-include-sysmacros.patch50
2 files changed, 54 insertions, 2 deletions
diff --git a/community/udisks/APKBUILD b/community/udisks/APKBUILD
index 810d48a97d..7835e5b3d7 100644
--- a/community/udisks/APKBUILD
+++ b/community/udisks/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=udisks
pkgver=1.0.5
-pkgrel=3
+pkgrel=4
pkgdesc="Disk Management Service"
url="http://www.freedesktop.org/wiki/Software/udisks"
arch="all"
@@ -15,6 +15,7 @@ makedepends="glib-dev polkit-dev parted-dev libgudev-dev sg3_utils-dev
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://hal.freedesktop.org/releases/$pkgname-$pkgver.tar.gz
udisks-uhelper.patch
+ udisks-include-sysmacros.patch
"
builddir="$srcdir"/$pkgname-$pkgver
@@ -40,4 +41,5 @@ package() {
}
sha512sums="bdf4970113975221ff0e17866db18fd969ff9c8e1e851c8ad7572630814ab0c46b59df59433edcb2e7cc41cc8152afd35807f45e07f6d0fa87b21b5a77d0965a udisks-1.0.5.tar.gz
-f96d9626d1361af5ff80bd9a57a5adac2d7a0a12b1f47c446a623fe64c4e58f0e6d591bbc2ad7ca619fee09706fe13e8692f86219f2cc3ef825f055f765af2ce udisks-uhelper.patch"
+f96d9626d1361af5ff80bd9a57a5adac2d7a0a12b1f47c446a623fe64c4e58f0e6d591bbc2ad7ca619fee09706fe13e8692f86219f2cc3ef825f055f765af2ce udisks-uhelper.patch
+90682b197fd851fbdf5d1cc577f9a4b2dac766240ff925ecfe14e85bca4ae385007b846f2ac32e4794fcacf0f1a2799f969f65fc42aa1909c6bc77420624881e udisks-include-sysmacros.patch"
diff --git a/community/udisks/udisks-include-sysmacros.patch b/community/udisks/udisks-include-sysmacros.patch
new file mode 100644
index 0000000000..dc1c77fa01
--- /dev/null
+++ b/community/udisks/udisks-include-sysmacros.patch
@@ -0,0 +1,50 @@
+--- a/src/device.c
++++ b/src/device.c
+@@ -29,6 +29,7 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <sys/wait.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
+--- a/src/mount-monitor.c
++++ b/src/mount-monitor.c
+@@ -28,6 +28,7 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <sys/stat.h>
+ #include <mntent.h>
+
+--- a/src/daemon.c
++++ b/src/daemon.c
+@@ -39,6 +39,7 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
+ #include <sys/resource.h>
+--- a/tools/udisks.c
++++ b/tools/udisks.c
+@@ -29,6 +29,7 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <sys/stat.h>
+ #include <sys/wait.h>
+ #include <fcntl.h>
+--- a/tools/umount-udisks.c
++++ b/tools/umount-udisks.c
+@@ -29,6 +29,7 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <pwd.h>