aboutsummaryrefslogtreecommitdiffstats
path: root/community/unison
diff options
context:
space:
mode:
authorJean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>2020-02-26 15:37:06 +0100
committerAriadne Conill <ariadne@dereferenced.org>2020-03-23 09:51:53 +0000
commit1edfece632fc0d76629c810d415803dc51a5190b (patch)
tree59dcf7082e7af6587ceb3cd00ed2e0921d747c08 /community/unison
parent5f552ed0e5ebe7e94eb994c4f3d60b0470e1549c (diff)
downloadaports-1edfece632fc0d76629c810d415803dc51a5190b.tar.bz2
aports-1edfece632fc0d76629c810d415803dc51a5190b.tar.xz
mailmap/email: change my email-address
I use jean-louis.fuchs@adfinis-sygroup.ch in git from now on. Addition: increment pkgver and fix lint errors.
Diffstat (limited to 'community/unison')
-rw-r--r--community/unison/APKBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/community/unison/APKBUILD b/community/unison/APKBUILD
index 42cc4d334f..7d8a1b3eab 100644
--- a/community/unison/APKBUILD
+++ b/community/unison/APKBUILD
@@ -1,20 +1,20 @@
-# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
-# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
+# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=unison
# Note: unison breaks compatibility between minor (major.minor) versions.
pkgver=2.48.15_p4
_pkgver=${pkgver/_p/v}
_majorver=${_pkgver%.*} # x.y
-pkgrel=0
+pkgrel=1
pkgdesc="Efficient file-synchronization tool"
url="https://www.cis.upenn.edu/~bcpierce/unison/"
# ocaml is not built for x86, armhf, s390x
# ocaml-lablgtk is not built for aarch64
arch="all !x86 !armhf !armv7 !aarch64 !s390x"
-license="GPL-3.0+"
+license="GPL-3.0-or-later"
makedepends="ocaml ocaml-lablgtk-dev linux-headers emacs-nox bash"
subpackages="$pkgname-gui"
-source="$pkgname-$_pkgver.tar.gz::https://github.com/bcpierce00/$pkgname/archive/v$_pkgver.tar.gz
+source="unison-$_pkgver.tar.gz::https://github.com/bcpierce00/unison/archive/v$_pkgver.tar.gz
fix-inotify-check.patch
makefile-fix-clean.patch
fix-for-lablgtk-2.18.6.patch
@@ -22,11 +22,9 @@ source="$pkgname-$_pkgver.tar.gz::https://github.com/bcpierce00/$pkgname/archive
# TODO: Enable check once this issue is fixed:
# https://github.com/bcpierce00/unison/issues/73
options="!check"
-builddir="$srcdir/$pkgname-$_pkgver/src"
+builddir="$srcdir/unison-$_pkgver/src"
build() {
- cd "$builddir"
-
# ocamlopt is a front-end for gcc which will create optimized ocaml
# binaries. It will call gcc, but it hasn't implemented all gcc options.
# -ccopt is the way to pass arbitrary options.
@@ -45,7 +43,6 @@ build() {
}
package() {
- cd "$builddir"
install -m 755 -D unison-text \
"$pkgdir"/usr/bin/unison-text-$_majorver
install -m 755 -D unison-fsmonitor \