aboutsummaryrefslogtreecommitdiffstats
path: root/community/unit
diff options
context:
space:
mode:
authorJoe Searle <joe@jsearle.net>2019-09-22 15:04:15 +0000
committerJoe Searle <joe@jsearle.net>2019-09-22 15:04:15 +0000
commit122640be9513aa969eb555ccd007624edf12725d (patch)
tree1b565bc670fdf3312137a0b15fc1a20130dfbfaf /community/unit
parent50733f3dc6ea3a17c1efffac0250a96c8113c932 (diff)
downloadaports-122640be9513aa969eb555ccd007624edf12725d.tar.bz2
aports-122640be9513aa969eb555ccd007624edf12725d.tar.xz
community/unit: upgrade to 1.11.0
Diffstat (limited to 'community/unit')
-rw-r--r--community/unit/APKBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/community/unit/APKBUILD b/community/unit/APKBUILD
index af23427546..48fbf1d2d8 100644
--- a/community/unit/APKBUILD
+++ b/community/unit/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=unit
-pkgver=1.9.0
-pkgrel=1
+pkgver=1.11.0
+pkgrel=0
pkgdesc="NGINX Unit is a dynamic web application server"
url="https://unit.nginx.org/"
# x86: tests fail (https://github.com/nginx/unit/issues/118)
@@ -11,14 +11,15 @@ url="https://unit.nginx.org/"
arch="all"
license="Apache-2.0"
_phpver=7
-makedepends="perl-dev php$_phpver-dev php$_phpver-embed python3-dev ruby-dev"
+# linux-headers package needed until fixed 1.12 - see comments on commit (Russian)
+# https://github.com/nginx/unit/commit/c554941b4f826d83d92d5ca8d7713bea4167896e#comments
+makedepends="linux-headers perl-dev php$_phpver-dev php$_phpver-embed python3-dev ruby-dev"
install="$pkgname.pre-install"
subpackages="$pkgname-openrc"
-source="https://unit.nginx.org/download/$pkgname-$pkgver.tar.gz
+source="https://unit.nginx.org/download/unit-$pkgver.tar.gz
$pkgname.initd
$pkgname.confd
$pkgname.logrotate"
-builddir="$srcdir/$pkgname-$pkgver"
for _mod in perl php$_phpver python3 ruby; do
subpackages="$subpackages $pkgname-$_mod:_module"
@@ -27,8 +28,6 @@ done
_modules_dir="/usr/lib/unit/modules"
build() {
- cd "$builddir"
-
# Needed for building perl module.
export CFLAGS="$CFLAGS -D_LARGEFILE64_SOURCE"
@@ -52,8 +51,6 @@ build() {
}
check() {
- cd "$builddir"
-
./build/tests
# FIXME: Some tests are broken.
@@ -62,8 +59,6 @@ check() {
}
package() {
- cd "$builddir"
-
make unitd-install DESTDIR="$pkgdir"
install -D -m 755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
@@ -85,7 +80,7 @@ _module() {
make $modname-install DESTDIR="$subpkgdir"
}
-sha512sums="25beda88e3e92cace7acfee45a640c351f4e15f20f2aa0f047c3ba61351c6119f270754186f39ab3f1fcc16b1bef9009da4f507d5cdf511538825f2a4c879d62 unit-1.9.0.tar.gz
+sha512sums="894093385137bc188c50b86540182007bac1740a063359f494c1984687352eccb879f7d6b7b6623d5702cce3c793f12c60a2dfab94bcf9cb817b80a1577409d9 unit-1.11.0.tar.gz
a835b83284d7bd4afb445dd93c84e2c6dd5906f137784ff3189edc82c3f14f07c5de00681125924138e3ac420cc849cc93e52cabbd6b550ded09d055d30e091c unit.initd
f85112726dfcace2b6d94b10669615fef517f5aa10ac858890dd9f5c868a6e2569500f7411f758fcb24c98c9630760d36a74bd33ea510ab0f8ca8cd6cb1fb1e8 unit.confd
723e465162dfdb31881680200221542add414e54ef4f4f1fc57e91b7b57777dfb21c2eee4727ecbba0c1943bb77a2597cc0225b16e334c38258c296d15b1df74 unit.logrotate"