aboutsummaryrefslogtreecommitdiffstats
path: root/community/uthash
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-25 19:59:09 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-25 19:59:09 +0100
commit774cc85911a7fcdeedcbcb65d24ac1b029018494 (patch)
tree4d9ba802c1d1655007ea9693a9c23d5ca6a1a9eb /community/uthash
parent3d3d921f42f2dc2e23d34c93b7a8a1b1651ce550 (diff)
downloadaports-774cc85911a7fcdeedcbcb65d24ac1b029018494.tar.bz2
aports-774cc85911a7fcdeedcbcb65d24ac1b029018494.tar.xz
community/uthash: move from testing
Diffstat (limited to 'community/uthash')
-rw-r--r--community/uthash/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/community/uthash/APKBUILD b/community/uthash/APKBUILD
new file mode 100644
index 0000000000..04493d72d9
--- /dev/null
+++ b/community/uthash/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=uthash
+pkgver=2.0.2
+_sover=0 # based on Fedora package
+pkgrel=0
+pkgdesc="C macros for hash tables and more"
+url="http://troydhanson.github.io/uthash/"
+arch="all"
+license="BSD"
+depends_dev="$pkgname=$pkgver-r$pkgrel"
+checkdepends="perl"
+subpackages="$pkgname-dev libut"
+source="$pkgname-$pkgver.tar.gz::https://github.com/troydhanson/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ CFLAGS="$CFLAGS -fPIC" make -C libut
+ gcc -shared $CFLAGS $LDFLAGS -Wl,-soname,libut.so.$_sover \
+ -o libut/libut.so.$_sover libut/*.o
+}
+
+check() {
+ cd "$builddir"
+
+ make -C tests
+ make -C tests/threads
+ make -C libut/tests
+}
+
+package() {
+ cd "$builddir"
+
+ mkdir -p "$pkgdir"/usr/include \
+ "$pkgdir"/usr/lib
+
+ install -m 0644 src/*.h "$pkgdir"/usr/include/
+
+ install -m 0644 libut/libut.a "$pkgdir"/usr/lib/
+ install -D -m 0755 libut/libut.so.$_sover "$pkgdir"/usr/lib/
+ ln -s libut.so.$_sover "$pkgdir"/usr/lib/libut.so
+}
+
+libut() {
+ pkgdesc="Library-implementation of utvector"
+
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libut.so* "$subpkgdir"/usr/lib/
+}
+
+sha512sums="0c2e686eb5a1d6a03a6fa1d42e803fca4e9b60b2d965c635a5a33d487c8d115f1f8155ff99a0e1874b69f6b66c04ea7d8866472a39abe5d1a23ae73f6fa956d7 uthash-2.0.2.tar.gz"