aboutsummaryrefslogtreecommitdiffstats
path: root/community/vault
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-17 21:25:58 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-17 22:21:59 -0300
commit383c33c9817d73771d7a4c6054770f3b0ef13d99 (patch)
treec17f846a261455e682b69a1987e9a2577056044e /community/vault
parent2bc15df4a324397e381f0054a1224857c60e1ffc (diff)
downloadaports-383c33c9817d73771d7a4c6054770f3b0ef13d99.tar.bz2
aports-383c33c9817d73771d7a4c6054770f3b0ef13d99.tar.xz
community/vault: use supervise-daemon instead of start-stop-daemon
Diffstat (limited to 'community/vault')
-rw-r--r--community/vault/APKBUILD8
-rw-r--r--community/vault/vault.initd18
2 files changed, 12 insertions, 14 deletions
diff --git a/community/vault/APKBUILD b/community/vault/APKBUILD
index 005c2faa54..877e2d26c9 100644
--- a/community/vault/APKBUILD
+++ b/community/vault/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Gennady Feldman <gena01@gmail.com>
pkgname=vault
pkgver=1.2.2
-pkgrel=0
+pkgrel=1
pkgdesc="Vault is a tool for securely accessing secrets"
url="https://www.vaultproject.io/"
arch="all !s390x"
@@ -27,8 +27,6 @@ prepare() {
}
build() {
- cd "$builddir"
-
GOPATH="$srcdir" CGO_ENABLED=0 make static-dist prep
GOPATH="$srcdir" CGO_ENABLED=0 go build -v -o bin/$pkgname \
-ldflags "-X github.com/hashicorp/vault/version.GitDescribe='$pkgver'" \
@@ -36,8 +34,6 @@ build() {
}
package() {
- cd "$builddir"
-
install -m755 -D "$srcdir/$pkgname.initd" \
"$pkgdir/etc/init.d/$pkgname"
@@ -61,4 +57,4 @@ sha512sums="ce9211b3deb1839759646f8488fe2b89fec379bafed472921a62cd507f842ed05647
e551aa366287ca86436b14c72c254d739c2492dec7a877da135ba81bf2170bbe694f2ac98798d5855004a0aca406a27c1bdf0c791844f1bd330ea3a1160c6327 static-assets.patch
6f3f30e5c9d9dd5117f18fce0e669f0cd752a6be4910405d6b394f15273372731ee887a5ba4c700293e5b8bc2bf40fd69d4337156f77b03549d2dc2c0a666bec vault.confd
8c064aa5dcca84822c1fa85e9d0ff520df46f794b2e9c689a9b4f81f74279387b3aebc08b3ca26cf786c2fcf1a330e765bf5a511074c24f87e5346672346ba1c vault.hcl
-1e436932647b191e691f5c60bec4ad926588cee5119c7cbe61345249a6768472387b6dd8b19b954c8ac80fb97f6e68f93749229b216300b0438dbeb0bdb57957 vault.initd"
+dfaa3b246c51e527cda99ca12b18f52416286d2d0cbbe418ba01075dd43d54b7e8350a10985e96690a2768314326586e05a1ec931fcff7d8c78729f1869d3293 vault.initd"
diff --git a/community/vault/vault.initd b/community/vault/vault.initd
index 2ed3152b34..bb6c28f4a1 100644
--- a/community/vault/vault.initd
+++ b/community/vault/vault.initd
@@ -1,19 +1,21 @@
#!/sbin/openrc-run
-VAULT_LOG_FILE="/var/log/${SVCNAME}.log"
+supervisor=supervise-daemon
+name="Vault server"
description="Vault is a tool for securely accessing secrets"
-command=/usr/sbin/${SVCNAME}
+
+VAULT_LOG_FILE="/var/log/${RC_SVCNAME}.log"
+
+command=/usr/sbin/${RC_SVCNAME}
command_args="${vault_opts}"
-command_background="true"
-start_stop_daemon_args="-w 100 --user ${SVCNAME}:${SVCNAME} --stdout $VAULT_LOG_FILE --stderr $VAULT_LOG_FILE"
-pidfile="/run/${SVCNAME}.pid"
+command_user="${RC_SVCNAME}:${RC_SVCNAME}"
start_pre() {
- checkpath -f -m 0644 -o ${SVCNAME}:${SVCNAME} "$VAULT_LOG_FILE"
+ checkpath -f -m 0644 -o "$command_user" "$VAULT_LOG_FILE"
}
depend() {
- need net
- after firewall
+ need net
+ after firewall
}