aboutsummaryrefslogtreecommitdiffstats
path: root/community/vault
diff options
context:
space:
mode:
authorMatthias Neugebauer <mtneug@mailbox.org>2019-12-17 14:02:26 +0100
committerRasmus Thomsen <oss@cogitri.dev>2019-12-23 00:14:44 +0100
commitaac9550febd092327195f4b3e263ca0b4b1a5709 (patch)
treed26090da13a0227dc8db0d3c42b1f35e5a2407f1 /community/vault
parentfbd444c6b36f470e59435de6b1028d5b6ff1a83b (diff)
downloadaports-aac9550febd092327195f4b3e263ca0b4b1a5709.tar.bz2
aports-aac9550febd092327195f4b3e263ca0b4b1a5709.tar.xz
community/vault: upgrade to 1.3.1
Diffstat (limited to 'community/vault')
-rw-r--r--community/vault/APKBUILD6
-rw-r--r--community/vault/go-mod-thrift.patch16
2 files changed, 20 insertions, 2 deletions
diff --git a/community/vault/APKBUILD b/community/vault/APKBUILD
index 8d7b2a8106..bcea269a6b 100644
--- a/community/vault/APKBUILD
+++ b/community/vault/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Christian Kampka <christian@kampka.net>
# Maintainer: Gennady Feldman <gena01@gmail.com>
pkgname=vault
-pkgver=1.2.4
+pkgver=1.3.1
pkgrel=0
pkgdesc="Vault is a tool for securely accessing secrets"
url="https://www.vaultproject.io/"
@@ -14,6 +14,7 @@ pkggroups="vault"
subpackages="$pkgname-openrc"
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/$pkgname/archive/v$pkgver.tar.gz
+ go-mod-thrift.patch
static-assets.patch
vault.confd
vault.hcl
@@ -45,7 +46,8 @@ package() {
install -m750 -o vault -g vault -d "$pkgdir/var/lib/$pkgname"
}
-sha512sums="35a91088ac6949863e2de651edac19d73586acc2f42d14e48d3b41236d9458c95e60f8ec2285b3846ff04ebe59a4d4b308686151d758b5af8caad711441e2ee4 vault-1.2.4.tar.gz
+sha512sums="082833136d4fd4ab0986243dc36c5b39786ab379eb30d21096412bd68a4f5024b24ebc9ebd07cbcf6ef65e3a6753774dd4f38c57b071ce6b126d54ef53c100bb vault-1.3.1.tar.gz
+66829e576ed54f8b228467d851446ce866fbda51c4e162aba3f83f719067c810dba12960e5ae42c93ba6bc14f703cd7c032f2fda004cfe11fe9449f78a074c58 go-mod-thrift.patch
e551aa366287ca86436b14c72c254d739c2492dec7a877da135ba81bf2170bbe694f2ac98798d5855004a0aca406a27c1bdf0c791844f1bd330ea3a1160c6327 static-assets.patch
6f3f30e5c9d9dd5117f18fce0e669f0cd752a6be4910405d6b394f15273372731ee887a5ba4c700293e5b8bc2bf40fd69d4337156f77b03549d2dc2c0a666bec vault.confd
8c064aa5dcca84822c1fa85e9d0ff520df46f794b2e9c689a9b4f81f74279387b3aebc08b3ca26cf786c2fcf1a330e765bf5a511074c24f87e5346672346ba1c vault.hcl
diff --git a/community/vault/go-mod-thrift.patch b/community/vault/go-mod-thrift.patch
new file mode 100644
index 0000000000..f6c7c92cd0
--- /dev/null
+++ b/community/vault/go-mod-thrift.patch
@@ -0,0 +1,16 @@
+This is a temporal fix for version 1.3.x when compiling with Go 1.13+. The change
+was already applied upstream and will be part of newer Vault versions:
+https://github.com/hashicorp/vault/commit/fa245e6a1db4bd8b8328c6c1a9850269078a5da9
+diff --git a/go.mod b/go.mod
+index d4bb30da1..a63584817 100644
+--- a/go.mod
++++ b/go.mod
+@@ -2,8 +2,6 @@ module github.com/hashicorp/vault
+
+ go 1.12
+
+-replace git.apache.org/thrift.git => github.com/apache/thrift v0.12.0
+-
+ replace github.com/hashicorp/vault/api => ./api
+
+ replace github.com/hashicorp/vault/sdk => ./sdk