aboutsummaryrefslogtreecommitdiffstats
path: root/community/vdesk
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-06-27 10:17:05 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-07-04 11:42:28 +0200
commit2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd (patch)
tree97c60fb3221dfe78cd7ccfda5db6125c81d5f676 /community/vdesk
parent00e8ff605f1c4f6386596f35f2a5287ff9b8bc55 (diff)
downloadaports-2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd.tar.bz2
aports-2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd.tar.xz
testing/[various]: move packages to community
Moves the packages listed below from the testing to the community repository after successfully testing of said packages. asciinema at calcurse cmus compton cpio dvd+rw-tools fortune fvwm geary h2o heirloom-mailx leafpad nedit nmh rover tor torsocks urlview vdesk w3m wbar xcalc xclock xeyes xkill
Diffstat (limited to 'community/vdesk')
-rw-r--r--community/vdesk/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/vdesk/APKBUILD b/community/vdesk/APKBUILD
new file mode 100644
index 0000000000..1352649626
--- /dev/null
+++ b/community/vdesk/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=vdesk
+pkgver=1.2
+pkgrel=0
+pkgdesc="vdesk is a virtual desktop manager."
+url="http://offog.org/code/vdesk/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="libx11-dev"
+install=""
+subpackages=""
+source="http://offog.org/files/${pkgname}-${pkgver}.tar.gz"
+
+_builddir=${srcdir}/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ }
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr || return 1
+ make || return 1
+ }
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="8c434dc188c868f19e57674074489481 vdesk-1.2.tar.gz"
+sha256sums="4ac9af40591abcb3a99dea9331933182af7a7c4d0c2eec43be37cf2c21dfa792 vdesk-1.2.tar.gz"
+sha512sums="0812c363bf51e4b602f3789f73588a8f6bedc6a8803030a71e7b4cd29945b73e9ce31f917845f448a6b318cf2e51b76f954271b28c3ecf239b86333b5f74aea4 vdesk-1.2.tar.gz"