aboutsummaryrefslogtreecommitdiffstats
path: root/community/vim-editorconfig/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-23 19:11:50 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-23 19:11:50 +0200
commit777b9125829ffc29a1d50428a5059350d5053132 (patch)
tree5044129424824ed7aa57f9371b37d907dafd530a /community/vim-editorconfig/APKBUILD
parent7536f303a4826647868a57542d67d625db7b9c1d (diff)
downloadaports-777b9125829ffc29a1d50428a5059350d5053132.tar.bz2
aports-777b9125829ffc29a1d50428a5059350d5053132.tar.xz
community/editorconfig: move from testing
Diffstat (limited to 'community/vim-editorconfig/APKBUILD')
-rw-r--r--community/vim-editorconfig/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/vim-editorconfig/APKBUILD b/community/vim-editorconfig/APKBUILD
new file mode 100644
index 0000000000..937d779373
--- /dev/null
+++ b/community/vim-editorconfig/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=vim-editorconfig
+pkgver=0_git20170721
+_gitrev=14ad5ced8b9daad219f1e48b121dbbd66c20d3a6
+pkgrel=0
+pkgdesc="EditorConfig plugin for vim written in vimscript only"
+url="https://github.com/sgur/vim-editorconfig"
+arch="noarch"
+license="MIT"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sgur/$pkgname/archive/$_gitrev.tar.gz
+ fix-config-parsing.patch"
+builddir="$srcdir/$pkgname-$_gitrev"
+options="!check" # there are no tests
+
+package() {
+ local destdir="$pkgdir/usr/share/vim/vimfiles"
+ cd "$builddir"
+
+ mkdir -p "$destdir"
+ cp -r autoload doc ftdetect ftplugin plugin "$destdir"/
+}
+
+sha512sums="61deaedcb6034f6de2cb8bb28e23a1aba2ca74fdf482421078f50c832d2128663bb89279534e7b2e37a00ba7b2cd5dd1d080c452975761fcac7a29a07ce69576 vim-editorconfig-0_git20170721.tar.gz
+d2b17733aa77d50326807d033cacffb74eb4fdf91721255ff58c1821e3488cb46f0014f73afc5630dc75c2a6ea3ee91c37699433326bf4ee9eed80a2ed709620 fix-config-parsing.patch"