aboutsummaryrefslogtreecommitdiffstats
path: root/community/vpcs
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-03-04 16:30:11 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-03-04 16:30:11 +0000
commit6856a4f49b1c8de2720e9995be1f079d45f6cda0 (patch)
treef4c3b898c0e6ddbd2f5d30a594c56994117398c0 /community/vpcs
parent659ef779f87acd391076d5436e5450a3ea0b040a (diff)
downloadaports-6856a4f49b1c8de2720e9995be1f079d45f6cda0.tar.bz2
aports-6856a4f49b1c8de2720e9995be1f079d45f6cda0.tar.xz
community/vpcs: update APKBUILD, added check()
Diffstat (limited to 'community/vpcs')
-rw-r--r--community/vpcs/APKBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/community/vpcs/APKBUILD b/community/vpcs/APKBUILD
index 04aeeaa131..735e096159 100644
--- a/community/vpcs/APKBUILD
+++ b/community/vpcs/APKBUILD
@@ -7,30 +7,26 @@ pkgdesc="Simple virtual PC simulator"
url="https://sourceforge.net/projects/vpcs/"
arch="x86 x86_64"
license="BSD"
-depends=""
-depends_dev=""
-makedepends="$depends_dev linux-headers bsd-compat-headers"
-install=""
-subpackages=""
+makedepends="linux-headers bsd-compat-headers"
source="https://github.com/GNS3/${pkgname}/archive/v${pkgver}beta1.tar.gz
musl-fixes.patch"
-
builddir="$srcdir"/$pkgname-${pkgver}beta1/src
+
build() {
cd "$builddir"
-# patch -p2 < "$srcdir"/header-fixes.fix
./mk.sh $(getconf LONG_BIT)
}
+check() {
+ cd "$builddir"
+ ./vpcs -v || test $? = 2
+}
+
package() {
cd "$builddir"
mkdir -p "$pkgdir/usr/bin"
install -Dm755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
}
-md5sums="c02fa7181e6a66403318b3680368ae53 v0.8beta1.tar.gz
-307cad46d45a35688e1e839eb46c4244 musl-fixes.patch"
-sha256sums="769358f29353001f6eb374a49fe6569b36b46b2730166e8e11633c6dbdaaff92 v0.8beta1.tar.gz
-9ed5548a0b0346ac976ea4758ab166bc5006f8b85a8d18caa6a9839712d38d44 musl-fixes.patch"
sha512sums="9d090613c3d59c9952d89739eb4fbdcf67f45f26e19e2999d94f82b5f026cc263265f33eea7db56d6fae8c59d4b954ee184d4bfe80d7dd22ae08c5d6f9090486 v0.8beta1.tar.gz
b0ffc373e436e93a959b3d0ce30de9415cad1e761aae27444d1c99ac585cab9676d939143248d55334e1e0cefcbfa2ae75943fd74eec2221d7292f349aa334c7 musl-fixes.patch"