aboutsummaryrefslogtreecommitdiffstats
path: root/community/webkit2gtk
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-07-03 09:18:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-07-04 10:25:29 +0000
commit35071c4a6abc7c373ce18fe0e3865dbfca90fbee (patch)
tree377ec7b9007a80de435b3535e899fa05f507c873 /community/webkit2gtk
parent4fd81015c0e664f0b9c98743f5e356c3d83d3904 (diff)
downloadaports-35071c4a6abc7c373ce18fe0e3865dbfca90fbee.tar.bz2
aports-35071c4a6abc7c373ce18fe0e3865dbfca90fbee.tar.xz
community/webkit2gtk: upgrade to 2.24.3 and enable on arm
- build with MinSizeRel and -g1 to reduce memory usage during compile - simplify cmake opts. default seems to do the right thing nowdays - use nijna - remove patch that apparetnly is not needed anymore
Diffstat (limited to 'community/webkit2gtk')
-rw-r--r--community/webkit2gtk/APKBUILD38
-rw-r--r--community/webkit2gtk/fix_armv6l.patch23
2 files changed, 16 insertions, 45 deletions
diff --git a/community/webkit2gtk/APKBUILD b/community/webkit2gtk/APKBUILD
index 0ffa40ed90..33c2d59118 100644
--- a/community/webkit2gtk/APKBUILD
+++ b/community/webkit2gtk/APKBUILD
@@ -3,11 +3,11 @@
# Contributor: Jiri Horner <laeqten@gmail.com>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=webkit2gtk
-pkgver=2.24.2
+pkgver=2.24.3
pkgrel=0
pkgdesc="Portable web rendering engine WebKit for GTK+"
url="https://webkitgtk.org/"
-arch="all !armhf !armv7 !x86" # Not enough memory to allocate in 32bit systems
+arch="all !x86" # x86 fails with: cc1plus: out of memory allocating 65536 bytes after a total of 3131101184 bytes
license="LGPL-2.0-or-later AND BSD-2-Clause"
makedepends="
bison
@@ -35,6 +35,7 @@ makedepends="
libxslt-dev
libxt-dev
mesa-dev
+ ninja
openjpeg-dev
openjpeg-tools
pango-dev
@@ -48,7 +49,6 @@ options="!check" # upstream doesn't package them in release tarballs: Tools/Scri
subpackages="$pkgname-dev $pkgname-lang"
source="https://webkitgtk.org/releases/webkitgtk-$pkgver.tar.xz
fix-fast-memory-disabled.patch
- fix_armv6l.patch
musl-fixes.patch
fix-openjpeg.patch
"
@@ -100,21 +100,18 @@ builddir="$srcdir/webkitgtk-$pkgver"
build() {
local _archopt=
case "$CARCH" in
- x86) export CFLAGS="$CFLAGS -msse2"
- _archopt="-DENABLE_JIT=OFF"
- ;;
- armhf) _archopt="-DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON";;
- armv7) _archopt="-DENABLE_JIT=OFF -DENABLE_C_LOOP=ON";;
- aarch64) _archopt="-DUSE_LD_GOLD=OFF";;
- ppc64le) _archopt="-DENABLE_JIT=OFF -DENABLE_C_LOOP=ON";;
- s390x) _archopt="-DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF -ENABLE_C_LOOP=ON";;
+ armhf|armv7|ppc64le|s390x) _archopt="-DENABLE_JIT=OFF";;
esac
+ # reduce memory usage on 32 bit
+ # https://bugs.webkit.org/show_bug.cgi?id=199272
+ export CXXFLAGS="$CXXFLAGS -g1"
+
mkdir build
cd build
- cmake \
+ cmake -GNinja \
-DPORT=GTK \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_SKIP_RPATH=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_INSTALL_DIR=/usr/lib \
@@ -124,28 +121,25 @@ build() {
-DENABLE_SAMPLING_PROFILER=OFF \
-DENABLE_MINIBROWSER=ON \
-DUSE_WOFF2=OFF \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
$_archopt \
..
-
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=923476
- make JavaScriptCore-4-gir
- make
+ ninja JavaScriptCore-4-gir
+ ninja
}
check() {
- cd "$builddir"/build
- make check
+ ninja -C "$builddir"/build check
}
package() {
- cd "$builddir"/build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C "$builddir"/build install
# needed for JIT
paxmark -m "$pkgdir"/usr/libexec/webkit2gtk-4.0/WebKitWebProcess
}
-sha512sums="8376167cfc4530886a2ac644ab84ff1021a63f6236d7be9eeb9e0ecade8bad5384b652dfe3720fdd31cddb39df6c935f859f1c0a59f42d7c71998992c4a9ffaa webkitgtk-2.24.2.tar.xz
+sha512sums="b358bb11f7df477e5b3d6a12e2e6b41cb4e6a7274e34ce6299bf0c56044ffc7db5a834e9abf5c71d992ef41d194d30171b8be406420ffc54fe766cc811afb79f webkitgtk-2.24.3.tar.xz
e1537b9937af1cb936669d405993a52204cb9968b8b3161cb12a3f3f1343c260088c9490fcd7a7deeab6dbabdb5f7ce7e6cb2f857b9f0a4205aba6db2b11fb20 fix-fast-memory-disabled.patch
-c567eeac3c5f87b12711b40269946be0996df7fd73790d46fed64100c79240fbc965200ba702ef73a091e08ef9c949aebced62a7e4f5aab4f9b657d7dd808802 fix_armv6l.patch
d0d5e37822644cab071e33d325affd1ce5948b414f6f54d695e6b4a7bffadecd25c0df6dc1cb63e70127499f5a8da43b02286a3518b2488b5da32c622df45d97 musl-fixes.patch
c517c012f5630ef6be5be7d9592c5e042a070f849a141859edefa7984acb98dbd0d718fe6613cd35ba3b7d8530beebcc7408fd077cd914ed335c5e524e9e746a fix-openjpeg.patch"
diff --git a/community/webkit2gtk/fix_armv6l.patch b/community/webkit2gtk/fix_armv6l.patch
deleted file mode 100644
index aaaac01c2d..0000000000
--- a/community/webkit2gtk/fix_armv6l.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Fix code emitted for armv6l to not use movw/movt but ldr.
-See https://bugs.webkit.org/show_bug.cgi?id=131612
-and https://bugs.webkit.org/show_bug.cgi?id=141288
-
---- a/Source/JavaScriptCore/offlineasm/arm.rb
-+++ b/Source/JavaScriptCore/offlineasm/arm.rb
-@@ -537,8 +537,16 @@
- $asm.puts "mov #{armFlippedOperands(operands)}"
- end
- when "mvlbl"
-+ if isARMv7 or isARMv7Traditional
- $asm.puts "movw #{operands[1].armOperand}, \#:lower16:#{operands[0].value}"
- $asm.puts "movt #{operands[1].armOperand}, \#:upper16:#{operands[0].value}"
-+ else
-+ $mvlbl_counter ||= 0
-+ $mvlbl_counter += 1
-+ const_label = "_mvlbl_const_label#{$mvlbl_counter}"
-+ $asm.puts ".equ #{const_label}, (#{operands[0].value})"
-+ $asm.puts "ldr #{operands[1].armOperand}, =#{const_label}"
-+ end
- when "nop"
- $asm.puts "nop"
- when "bieq", "bpeq", "bbeq"