aboutsummaryrefslogtreecommitdiffstats
path: root/community/webkit2gtk
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-07-05 15:52:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-07-05 15:59:21 +0000
commitabb0170b9be48010a5d6586c1f568c703b643f14 (patch)
tree7658cf4f470fcac461da4fa890fec8e025c4ce5d /community/webkit2gtk
parent9e016dcfd6d790898c57f069cc8dc7d7fe89e78e (diff)
downloadaports-abb0170b9be48010a5d6586c1f568c703b643f14.tar.bz2
aports-abb0170b9be48010a5d6586c1f568c703b643f14.tar.xz
community/webkit2gtk: enable on x86
Enable x86 and work around out of meomory error by disable _FORTIFY_SOURCE.
Diffstat (limited to 'community/webkit2gtk')
-rw-r--r--community/webkit2gtk/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/community/webkit2gtk/APKBUILD b/community/webkit2gtk/APKBUILD
index 33c2d59118..1dd6c0b737 100644
--- a/community/webkit2gtk/APKBUILD
+++ b/community/webkit2gtk/APKBUILD
@@ -7,7 +7,7 @@ pkgver=2.24.3
pkgrel=0
pkgdesc="Portable web rendering engine WebKit for GTK+"
url="https://webkitgtk.org/"
-arch="all !x86" # x86 fails with: cc1plus: out of memory allocating 65536 bytes after a total of 3131101184 bytes
+arch="all"
license="LGPL-2.0-or-later AND BSD-2-Clause"
makedepends="
bison
@@ -100,6 +100,9 @@ builddir="$srcdir/webkitgtk-$pkgver"
build() {
local _archopt=
case "$CARCH" in
+ # disable _FORTIFY_SOURCE to work around:
+ # cc1plus: out of memory allocating 65536 bytes after a total of 3131101184 bytes
+ x86) CXXFLAGS="$CXXFLAGS -U_FORTIFY_SOURCE";;
armhf|armv7|ppc64le|s390x) _archopt="-DENABLE_JIT=OFF";;
esac