aboutsummaryrefslogtreecommitdiffstats
path: root/community/wine/APKBUILD
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-02-10 21:45:37 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-06-23 11:24:50 -0300
commit8b6025729e7e7abe1752d2c4be5a574337ec794a (patch)
treea48df205988d397a7bb50d975be9663a2bba1206 /community/wine/APKBUILD
parent56dce0fdb84102d1371da0d1087dfe2d0c550751 (diff)
downloadaports-8b6025729e7e7abe1752d2c4be5a574337ec794a.tar.bz2
aports-8b6025729e7e7abe1752d2c4be5a574337ec794a.tar.xz
community/wine: upgrade to 4.0.1
Diffstat (limited to 'community/wine/APKBUILD')
-rw-r--r--community/wine/APKBUILD46
1 files changed, 19 insertions, 27 deletions
diff --git a/community/wine/APKBUILD b/community/wine/APKBUILD
index c58034bf0e..e665901ad0 100644
--- a/community/wine/APKBUILD
+++ b/community/wine/APKBUILD
@@ -5,24 +5,23 @@
# Contributor: Martell Malone <martell@marinelayer.io>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wine
-pkgver=3.0.4
+pkgver=4.0.1
_pkgver=${pkgver/_/-}
-pkgrel=1
+pkgrel=0
pkgdesc="A compatibility layer for running Windows programs"
url="https://www.winehq.org"
arch="x86 x86_64"
license="LGPL-2.0-or-later"
-# As of 2.0.3 most of the tests fails
-options="!check"
-subpackages="$pkgname-libs $pkgname-dev $pkgname-doc"
+options="!check" # As of 2.0.3 most of the tests fails
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
depends_dev="$pkgname perl"
-makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
- libxcursor-dev libxrandr-dev libxdamage-dev mesa-dev flex-dev bison
- libpng-dev libjpeg-turbo-dev freetype-dev ncurses-dev openssl-dev
- libxcomposite-dev libxrender-dev libxinerama-dev zlib-dev
- cups-dev alsa-lib-dev lcms-dev libxml2-dev paxmark dbus-dev libxi-dev
- gnutls-dev tiff-dev v4l-utils-dev udisks2-dev autoconf automake
+makedepends="alsa-lib-dev autoconf automake bison cups-dev dbus-dev flex-dev
+ fontconfig-dev freetype-dev gnutls-dev lcms-dev libjpeg-turbo-dev libpng-dev
+ libxcomposite-dev libxcursor-dev libxdamage-dev libxi-dev libxinerama-dev
+ libxml2-dev libxrandr-dev libxrender-dev libxslt-dev libxxf86dga-dev mesa-dev
+ ncurses-dev openldap-dev openssl-dev tiff-dev udisks2-dev v4l-utils-dev zlib-dev
"
+checkdepends="xvfb-run"
source="https://dl.winehq.org/$pkgname/source/${pkgver%.[1-9]}/$pkgname-$_pkgver.tar.xz
no-pie.patch
wine-dlclose-bug41703.patch
@@ -31,15 +30,11 @@ source="https://dl.winehq.org/$pkgname/source/${pkgver%.[1-9]}/$pkgname-$_pkgver
builddir="$srcdir/$pkgname-$_pkgver"
prepare() {
- cd "$builddir"
-
default_prepare
aclocal && autoheader && autoreconf
}
build() {
- cd "$builddir"
-
case "$CARCH" in
x86_64) _win64=--enable-win64;;
esac
@@ -57,13 +52,10 @@ build() {
}
check() {
- cd "$builddir"
- make test
+ xvfb-run make test
}
package() {
- local file
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
case "$CARCH" in
@@ -71,12 +63,10 @@ package() {
*) _wine="wine";;
esac
- paxmark -psmre "$pkgdir"/usr/bin/$_wine-preloader \
- "$pkgdir"/usr/bin/$_wine
-
install -Dm755 tools/wineapploader \
"$pkgdir"/usr/bin/wineapploader
+ local file
for file in msiexec notepad regedit regsvr32 wineboot \
winecfg wineconsole winefile winemine winepath
do
@@ -86,10 +76,11 @@ package() {
}
dev() {
- local file
default_dev
install -d "$subpkgdir"/usr/bin
+
+ local file
for file in widl wmc wrc winebuild winedump function_grep.pl \
winedbg winemaker winegcc winecpp wineg++
do
@@ -106,10 +97,11 @@ doc() {
}
libs() {
- local file ext
default_libs
install -d "$subpkgdir"/usr/lib/wine/fakedlls
+
+ local file ext
for ext in dll16 drv16 exe16 acm dll drv ds ocx sys tlb vxd; do
for file in $(find "$pkgdir/usr/lib/wine/fakedlls" -name "*.$ext"); do
mv "$pkgdir"/usr/lib/wine/fakedlls/${file##*/} \
@@ -120,7 +112,7 @@ libs() {
done
}
-sha512sums="e1ce33bbc165a9c640a38965a229b757b67746f2150d545eb0e29ba6d21cdf150bd8eb9a450d8dd71733fbea3b2ac24839dd8e381b7da9cd15ddf98c59304198 wine-3.0.4.tar.xz
-d853875f7d659617bdfba364704abd75b760d12977f1f13acc73acb3c8fefec0549677fb79a4f8955e073d64078b3071d63d97262522e22b7832a66d3d820a9c no-pie.patch
-0701cfa947c40adfadf5e8e6cee677d6588404fce7081e66c284e75ed50a0bc2144a89d8d2ad12ac7450910e4c8f77fa26298ab0f8743148308bc508f18acf6b wine-dlclose-bug41703.patch
+sha512sums="dd240525e389f841123a569fd2f9b8da698b7707bc0de408dfd60ae73c5e24d522abb42b76571c840df52c686fdeae56e0a9c69db2cd31f04cdb345feeacf1dc wine-4.0.1.tar.xz
+e4dc94f9438c50b6bbd210edf2b9145c61fdf53da239de3fffcdb42d290c4333fc28ca06c7c7ae7c09ca643ed86c86d4de3c40b9f15809ce5e1c0d608321e87c no-pie.patch
+6c8cde76d32cd7ba1c22bc4f2ce41dc354218f58a35aaa6717b594124994a97df84fc69fd6c02fea118ec03ed6e93bf13f05d14a0d8bf3291955664ba27cb51f wine-dlclose-bug41703.patch
522a94a31fc459e80ea7dd05f7aee64f6ae666ec05236d06614acde118d5c60002e0f253ae75edb5f02164f22937ca89578504b690d1a5611bd60f703c8f0c00 winhlp32-flex.patch"